aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorThomas Wood <thomas@openedhand.com>2006-10-30 10:38:50 +0000
committerThomas Wood <thomas@openedhand.com>2006-10-30 10:38:50 +0000
commit7597d5ba90cbcf3f0439fbabb62d7c718b249415 (patch)
tree71f7fbde5c069330a07d4130e5b9b7023910636a /meta
parent2db354074d4cb8d550f69ed63df18a7f3127990b (diff)
downloadopenembedded-core-contrib-7597d5ba90cbcf3f0439fbabb62d7c718b249415.tar.gz
Smaller filechooser patch for GTK+
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@840 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch47
-rw-r--r--meta/packages/gtk+/gtk+_2.6.8.bb3
2 files changed, 49 insertions, 1 deletions
diff --git a/meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch b/meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch
new file mode 100644
index 0000000000..3c6f7217e5
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch
@@ -0,0 +1,47 @@
+Index: gtkfilechooserdefault.c
+===================================================================
+RCS file: /cvs/gnome/gtk+/gtk/gtkfilechooserdefault.c,v
+retrieving revision 1.240.2.25
+diff -u -p -r1.240.2.25 gtkfilechooserdefault.c
+--- gtk+/gtk/gtkfilechooserdefault.c 7 Jul 2005 17:14:09 -0000 1.240.2.25
++++ gtk+/gtk/gtkfilechooserdefault.c 27 Oct 2006 14:22:28 -0000
+@@ -3728,6 +3728,7 @@ browse_widgets_create (GtkFileChooserDef
+ GtkWidget *vbox;
+ GtkWidget *hpaned;
+ GtkWidget *widget;
++ GtkWidget *shortcuts_pane;
+ GtkSizeGroup *size_group;
+
+ /* size group is used by the [+][-] buttons and the filter combo */
+@@ -3740,12 +3741,29 @@ browse_widgets_create (GtkFileChooserDef
+ gtk_paned_set_position (GTK_PANED (hpaned), 200); /* FIXME: this sucks */
+ gtk_box_pack_start (GTK_BOX (vbox), hpaned, TRUE, TRUE, 0);
+
+- widget = shortcuts_pane_create (impl, size_group);
+- gtk_paned_pack1 (GTK_PANED (hpaned), widget, FALSE, FALSE);
++ shortcuts_pane = shortcuts_pane_create (impl, size_group);
++ gtk_paned_pack1 (GTK_PANED (hpaned), shortcuts_pane, FALSE, FALSE);
+ widget = file_pane_create (impl, size_group);
+ gtk_paned_pack2 (GTK_PANED (hpaned), widget, TRUE, FALSE);
+
+ g_object_unref (size_group);
++
++
++ /* remove excess baggage from the filechooser for small displays */
++
++ /* get the columns in the tree view and remove the last column (should be Modified column) */
++ GList *column_list;
++ column_list = gtk_tree_view_get_columns (GTK_TREE_VIEW (impl->browse_files_tree_view));
++ gtk_tree_view_remove_column (GTK_TREE_VIEW (impl->browse_files_tree_view), (g_list_last (column_list))->data);
++ g_list_free (column_list);
++
++ /* hide the tree view headers */
++ gtk_tree_view_set_headers_visible (GTK_TREE_VIEW (impl->browse_files_tree_view), FALSE);
++
++ /* hide the shortcuts pane */
++ gtk_widget_hide (GTK_WIDGET (shortcuts_pane));
++
++
+
+ return vbox;
+ }
diff --git a/meta/packages/gtk+/gtk+_2.6.8.bb b/meta/packages/gtk+/gtk+_2.6.8.bb
index ee47448038..0b7ab6b313 100644
--- a/meta/packages/gtk+/gtk+_2.6.8.bb
+++ b/meta/packages/gtk+/gtk+_2.6.8.bb
@@ -17,7 +17,8 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://gtklabel-resize-patch;patch=1 \
file://menu-deactivate.patch;patch=1 \
file://scroll-timings.patch;patch=1 \
- file://no-deprecation.patch;patch=1"
+ file://no-deprecation.patch;patch=1 \
+ file://smaller-filechooser.patch;patch=1"
inherit autotools pkgconfig