aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTomas Frydrych <tf@openedhand.com>2006-11-03 09:20:26 +0000
committerTomas Frydrych <tf@openedhand.com>2006-11-03 09:20:26 +0000
commit73e003270527b95f502f4c2927adca385d8e6433 (patch)
tree9774f5b1baae49d797152216405f8e4a5f71b3c2 /meta
parent362a7a327673b15f398e53b386a854990c706f05 (diff)
downloadopenembedded-core-contrib-73e003270527b95f502f4c2927adca385d8e6433.tar.gz
tweaked to work with autotooled package
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@853 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/exmap-console/exmap-console.bb17
1 files changed, 4 insertions, 13 deletions
diff --git a/meta/packages/exmap-console/exmap-console.bb b/meta/packages/exmap-console/exmap-console.bb
index e4af4c1be4..929b27970a 100644
--- a/meta/packages/exmap-console/exmap-console.bb
+++ b/meta/packages/exmap-console/exmap-console.bb
@@ -2,19 +2,20 @@ DESCRIPTION = "console-based exmap"
HOMEPAGE = "http://www.o-hand.com"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r3"
+PR = "r5"
PV = "0.9"
-SRCDATE="20061026"
+SRCDATE="20061104"
SRC_URI = \
"svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http"
inherit module-base
+inherit autotools
S = "${WORKDIR}/exmap-console"
-export KERNEL_PATH=${STAGING_KERNEL_DIR}
+export MODULE_PATH="${D}${base_libdir}/modules/${KERNEL_VERSION}"
do_compile() {
cd ${S}/src
@@ -29,14 +30,4 @@ do_compile() {
${MAKE_TARGETS}
}
-sbindir="/usr/sbin"
-
-do_install() {
- install -d ${D}${sbindir}
- install -m 710 ${S}/src/exmap ${D}${sbindir}/exmap
-
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/misc
- install -m 644 ${S}/kernel/exmap${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/misc/
-}
-
FILES_${PN}="${sbindir} ${base_libdir}"