aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-01 11:26:28 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-01 11:26:28 +0000
commit1e2d2eb33a5fba729445a71ce855c4536c909de5 (patch)
tree1fdfb3918981274cc622cc32307dbfec1b9d0c5c /meta
parentea605d307c7935119ce75b411beb8890565f73fe (diff)
downloadopenembedded-core-contrib-1e2d2eb33a5fba729445a71ce855c4536c909de5.tar.gz
uboot: added U-Boot for fic-gta01
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1844 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/uboot/files/fix-arm920t-eabi.patch9
-rw-r--r--meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb18
-rw-r--r--meta/packages/uboot/uboot-gta01_svn.bb58
3 files changed, 85 insertions, 0 deletions
diff --git a/meta/packages/uboot/files/fix-arm920t-eabi.patch b/meta/packages/uboot/files/fix-arm920t-eabi.patch
new file mode 100644
index 0000000000..9896388c8f
--- /dev/null
+++ b/meta/packages/uboot/files/fix-arm920t-eabi.patch
@@ -0,0 +1,9 @@
+--- /tmp/config.mk 2007-02-14 17:23:15.000000000 +0100
++++ git/cpu/arm920t/config.mk 2007-02-14 17:23:38.475251000 +0100
+@@ -30,5 +30,5 @@
+ # Supply options according to compiler version
+ #
+ # =========================================================================
+-PLATFORM_CPPFLAGS +=$(call cc-option,-mapcs-32,-mabi=apcs-gnu)
++PLATFORM_CPPFLAGS +=$(call cc-option)
+ PLATFORM_RELFLAGS +=$(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
diff --git a/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb b/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
new file mode 100644
index 0000000000..7c10d653bc
--- /dev/null
+++ b/meta/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
@@ -0,0 +1,18 @@
+require uboot-gta01_svn.bb
+
+PROVIDES = ""
+TARGET_LDFLAGS = ""
+
+do_compile () {
+ chmod +x board/neo1973/gta01/split_by_variant.sh
+ oe_runmake gta01bv3_config
+ oe_runmake clean
+ oe_runmake tools
+}
+
+do_deploy () {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_package after do_install
diff --git a/meta/packages/uboot/uboot-gta01_svn.bb b/meta/packages/uboot/uboot-gta01_svn.bb
new file mode 100644
index 0000000000..d026efccc1
--- /dev/null
+++ b/meta/packages/uboot/uboot-gta01_svn.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "U-boot bootloader w/ Neo1973 (GTA01) support"
+AUTHOR = "Harald Welte <laforge@openmoko.org>"
+LICENSE = "GPL"
+SECTION = "bootloader"
+PRIORITY = "optional"
+PV = "1.2.0+svn${SRCDATE}"
+PR = "r3"
+
+PROVIDES = "virtual/bootloader"
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git \
+ svn://svn.openmoko.org/trunk/src/target/u-boot;module=patches;proto=http \
+ file://fix-arm920t-eabi.patch;patch=1"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
+UBOOT_MACHINES = "gta01v3 gta01v4 gta01bv2 gta01bv3"
+
+do_quilt() {
+ mv ${WORKDIR}/patches ${S}/patches
+ cd ${S}
+ quilt push -av
+ rm -Rf patches .pc
+}
+
+do_compile () {
+ chmod +x board/neo1973/split_by_variant.sh
+ for type in ram nand
+ do
+ for mach in ${UBOOT_MACHINES}
+ do
+ oe_runmake ${mach}_config
+ oe_runmake clean
+ if [ ${type} == "ram" ]; then
+ echo 'PLATFORM_RELFLAGS += -DBUILD_FOR_RAM' >> board/neo1973/config.tmp
+ fi
+ oe_runmake all
+ mv u-boot.bin u-boot_${mach}_${type}.bin
+ done
+ done
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ for type in nand ram
+ do
+ for mach in ${UBOOT_MACHINES}
+ do
+ install ${S}/u-boot_${mach}_${type}.bin ${DEPLOY_DIR_IMAGE}/u-boot_${type}-${mach}-${DATETIME}.bin
+ done
+ done
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile
+addtask quilt before do_patch after do_unpack