summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSinan Kaya <okaya@kernel.org>2020-12-16 22:25:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-12 17:43:05 +0000
commit28809742c517a8e3589b9cd22ce8e82b1a983683 (patch)
tree19da6506d29f8257adf5050605d70aeb53d3a87c /meta
parent938fe58625e2285ee529ee589908bb0d54810f01 (diff)
downloadopenembedded-core-contrib-28809742c517a8e3589b9cd22ce8e82b1a983683.tar.gz
procps: split ps and sysctl into individual packages
Move the ps and sysctl tools into its own package. Useful for size constrained systems that only want the ps and/or sysctl tools. Signed-off-by: Sinan Kaya <okaya@kernel.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/procps/procps_3.3.16.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.3.16.bb b/meta/recipes-extended/procps/procps_3.3.16.bb
index 2810ebd285..ef3ac86e97 100644
--- a/meta/recipes-extended/procps/procps_3.3.16.bb
+++ b/meta/recipes-extended/procps/procps_3.3.16.bb
@@ -74,3 +74,28 @@ python __anonymous() {
# 'ps' isn't suitable for use as a security tool so whitelist this CVE.
# https://bugzilla.redhat.com/show_bug.cgi?id=1575473#c3
CVE_CHECK_WHITELIST += "CVE-2018-1121"
+
+PROCPS_PACKAGES = "${PN}-lib \
+ ${PN}-ps \
+ ${PN}-sysctl"
+
+PACKAGE_BEFORE_PN = "${PROCPS_PACKAGES}"
+RDEPENDS_${PN} += "${PROCPS_PACKAGES}"
+
+RDEPENDS_${PN}-ps += "${PN}-lib"
+RDEPENDS_${PN}-sysctl += "${PN}-lib"
+
+FILES_${PN}-lib = "${libdir}"
+FILES_${PN}-ps = "${base_bindir}/ps.${BPN}"
+FILES_${PN}-sysctl = "${base_sbindir}/sysctl.${BPN} ${sysconfdir}/sysctl.conf ${sysconfdir}/sysctl.d"
+
+ALTERNATIVE_${PN}_remove = "ps"
+ALTERNATIVE_${PN}_remove = "sysctl"
+
+ALTERNATIVE_${PN}-ps = "ps"
+ALTERNATIVE_TARGET[ps] = "${base_bindir}/ps"
+ALTERNATIVE_LINK_NAME[ps] = "${base_bindir}/ps"
+
+ALTERNATIVE_${PN}-sysctl = "sysctl"
+ALTERNATIVE_TARGET[sysctl] = "${base_sbindir}/sysctl"
+ALTERNATIVE_LINK_NAME[sysctl] = "${base_sbindir}/sysctl" \ No newline at end of file