aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-05-03 00:21:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-03 11:25:57 +0100
commit544a96255203a6779d1f0022d003c6680f330511 (patch)
treedaa79a27bc3677bde29f3660bab741b893605cc2 /meta
parentcbc41a573dd3a073e7b862ca9d763ce815e8f927 (diff)
downloadopenembedded-core-contrib-544a96255203a6779d1f0022d003c6680f330511.tar.gz
curl: Backport a fix for a build issue
mkhelp: generate code for --disable-manual as well This allows configure --disable-manual to run and build without having to regenerate the src/tool_hugehelp.c file which otherwise is necessary since we ship tarballs with that file present. Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/curl/curl/generate_code_for_disable_manual.patch38
-rw-r--r--meta/recipes-support/curl/curl_7.36.0.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl/generate_code_for_disable_manual.patch b/meta/recipes-support/curl/curl/generate_code_for_disable_manual.patch
new file mode 100644
index 0000000000..dc755e44ad
--- /dev/null
+++ b/meta/recipes-support/curl/curl/generate_code_for_disable_manual.patch
@@ -0,0 +1,38 @@
+Upsteam-Status Backport [fixed in 7.37.0]
+commit 38d582ff541353d738858299d4a2b78bafac03ed
+Author: Daniel Stenberg <daniel@haxx.se>
+Date: Wed Mar 26 13:22:10 2014 +0100
+
+ mkhelp: generate code for --disable-manual as well
+
+ This allows configure --disable-manual to run and build without having
+ to regenerate the src/tool_hugehelp.c file which otherwise is necessary
+ since we ship tarballs with that file present.
+
+ Reported-by: Remi Gacogne
+ Bug: http://curl.haxx.se/bug/view.cgi?id=1350
+
+diff --git a/src/mkhelp.pl b/src/mkhelp.pl
+index 444b669..7ed86f7 100644
+--- a/src/mkhelp.pl
++++ b/src/mkhelp.pl
+@@ -6,7 +6,7 @@
+ # | (__| |_| | _ <| |___
+ # \___|\___/|_| \_\_____|
+ #
+-# Copyright (C) 1998 - 2011, Daniel Stenberg, <daniel@haxx.se>, et al.
++# Copyright (C) 1998 - 2014, Daniel Stenberg, <daniel@haxx.se>, et al.
+ #
+ # This software is licensed as described in the file COPYING, which
+ # you should have received as part of this distribution. The terms
+@@ -256,6 +256,10 @@ foot();
+
+ sub foot {
+ print <<FOOT
++#else /* !USE_MANUAL */
++/* built-in manual is disabled, blank function */
++#include "tool_hugehelp.h"
++void hugehelp(void) {}
+ #endif /* USE_MANUAL */
+ FOOT
+ ;
diff --git a/meta/recipes-support/curl/curl_7.36.0.bb b/meta/recipes-support/curl/curl_7.36.0.bb
index 6f5546321a..bd7191d284 100644
--- a/meta/recipes-support/curl/curl_7.36.0.bb
+++ b/meta/recipes-support/curl/curl_7.36.0.bb
@@ -11,6 +11,7 @@ DEPENDS_class-nativesdk = "nativesdk-zlib"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch \
+ file://generate_code_for_disable_manual.patch \
"
# curl likes to set -g0 in CFLAGS, so we stop it