aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-11-28 15:01:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-09 14:36:58 +0000
commit839f5ed91a8061506b1f71661ec4006783146672 (patch)
tree5e48cf62399569951f9c38482e81b42f47ee6489 /meta
parentd52a65d3d8512eeb5081d9fb5f18805428358241 (diff)
downloadopenembedded-core-contrib-839f5ed91a8061506b1f71661ec4006783146672.tar.gz
qemu: fix the makefile for ptest
It always fail to check the file generated by configure when running ptest on the target since it's cross-compiling, so remove the check from the Makefile for ptest. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.10.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_2.10.1.bb b/meta/recipes-devtools/qemu/qemu_2.10.1.bb
index 8e3ca3c949..5ac221c9ed 100644
--- a/meta/recipes-devtools/qemu/qemu_2.10.1.bb
+++ b/meta/recipes-devtools/qemu/qemu_2.10.1.bb
@@ -55,5 +55,8 @@ do_install_ptest() {
find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
+ # Don't check the file genreated by configure
+ sed -i -e '/wildcard config-host.mak/d' \
+ -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
}