aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2016-04-21 10:36:16 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-22 16:28:39 +0100
commit916650b91656fac4effde6d260006ba15f8ba23a (patch)
treeff11cfdef4e997cd3ed922b90d948cc0cda9742e /meta
parent10194ca3d8c2f4d8648a685c5c239a33d944b6fe (diff)
downloadopenembedded-core-contrib-916650b91656fac4effde6d260006ba15f8ba23a.tar.gz
valgrind: turn off the file level dependency
Attempting to install ptest for valgrind fails with this error: error: Can't install valgrind-ptest-3.11.0-r0.1@ppce500mc: no package provides /this/is/a/bogus/interpreter/name This is because one of the tests contains a bogus interpreter path on purpose It is not enough to skip the QA warning about the missing dependency but the dependency have to be completely removed. Since this package contains oly tests it is safe to disable per file dependencies and rely on the ones per package. Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.11.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
index 51c88bf7aa..824050075a 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.11.0.bb
@@ -68,9 +68,9 @@ RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
-# One of the tests contains a bogus interpreter path on purpose, and QA
-# check complains about it
-INSANE_SKIP_${PN}-ptest += "file-rdeps"
+# One of the tests contains a bogus interpreter path on purpose.
+# Skip file dependency check
+SKIP_FILEDEPS_${PN}-ptest = '1'
do_compile_ptest() {
oe_runmake check