summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-22 11:16:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-25 15:06:46 +0000
commit7aea6a938544582d036c454beeef947c986eedc7 (patch)
treee72962ab9399ab4c8a93f41345816034111bd65b /meta
parent44263ae8eb56966407cd8ca2c862daab342196f2 (diff)
downloadopenembedded-core-contrib-7aea6a938544582d036c454beeef947c986eedc7.tar.gz
bmap-tools: set PIP_INSTALL_PACKAGE, BASEVER
Change filename to _git.bb and use BASEVER to set PV. The wheel built by bdist_wheel is named "bmap_tool-*.whl" set the PIP_INSTALL_PACKAGE name accordingly. Use BASEVER to set PYPA_WHEEL to match the version in the wheel produced by bdist_wheel. [YOCTO #14638] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_git.bb (renamed from meta/recipes-support/bmap-tools/bmap-tools_3.6.bb)6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_3.6.bb b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
index 1e87d45c90..e3315321ed 100644
--- a/meta/recipes-support/bmap-tools/bmap-tools_3.6.bb
+++ b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
@@ -13,7 +13,8 @@ SRC_URI = "git://github.com/intel/${BPN};branch=master;protocol=https"
SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a"
S = "${WORKDIR}/git"
-PV .= "+git${SRCPV}"
+BASEVER = "3.6"
+PV = "${BASEVER}+git${SRCPV}"
UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
@@ -23,4 +24,7 @@ RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptoo
inherit python3native
inherit setuptools3
+PIP_INSTALL_PACKAGE = "bmap_tools"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-${BASEVER}-*.whl"
+
BBCLASSEXTEND = "native nativesdk"