summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-10 18:20:40 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-13 22:28:36 +0100
commit3386ab153608f584e6b7e17c4bd0554e2ab31c66 (patch)
tree3d5fa29834ddb0acf028dd0600ddeae5df317038 /meta
parent67a76eae50182da4426f35a96802f5d08b38e69b (diff)
downloadopenembedded-core-contrib-3386ab153608f584e6b7e17c4bd0554e2ab31c66.tar.gz
perl: Fix build for musl
The changes are covered under "${TARGET_OS}" = "linux-musl" Change-Id: I24a1a8e07abb35c7e3d64b372addfb3bd6f7731c Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index db65202ec8..d100ff9b82 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -165,6 +165,29 @@ do_configure() {
-e "s,-fstack-protector,-fno-stack-protector,g" \
config.sh-${TARGET_ARCH}-${TARGET_OS}
fi
+ # Fixups for musl
+ if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then
+ sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \
+ -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
+ -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
+ -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
+ -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
+ -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
+ -e "s,\(getprotobyname_r=\)'define',\1'undef',g" \
+ -e "s,\(getpwent_r=\)'define',\1'undef',g" \
+ -e "s,\(getservent_r=\)'define',\1'undef',g" \
+ -e "s,\(gethostent_r=\)'define',\1'undef',g" \
+ -e "s,\(getnetent_r=\)'define',\1'undef',g" \
+ -e "s,\(getnetbyaddr_r=\)'define',\1'undef',g" \
+ -e "s,\(getprotoent_r=\)'define',\1'undef',g" \
+ -e "s,\(getprotobynumber_r=\)'define',\1'undef',g" \
+ -e "s,\(getgrent_r=\)'define',\1'undef',g" \
+ -e "s,\(i_fcntl=\)'undef',\1'define',g" \
+ -e "s,\(h_fcntl=\)'false',\1'true',g" \
+ -e "s,-fstack-protector,-fno-stack-protector,g" \
+ -e "s,-lnsl,,g" \
+ config.sh-${TARGET_ARCH}-${TARGET_OS}
+ fi
${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}