aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-20 16:50:38 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-20 16:50:38 +0000
commitc6eae2fd67673639013006f32442e974243bc81e (patch)
treeb194539598eee06aba13a359ece9beae2584e17c /meta
parentb1ce4327e8a40b0ea4b6b249c5dca58a82a569e3 (diff)
downloadopenembedded-core-contrib-c6eae2fd67673639013006f32442e974243bc81e.tar.gz
linux-nokia770: Update kernel to osso26 release
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@889 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/linux/linux-nokia770_2.6.16-osso26.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb b/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb
new file mode 100644
index 0000000000..e980e8d7b2
--- /dev/null
+++ b/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb
@@ -0,0 +1,46 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Nokia 770"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo2.1/free/source/k/kernel-source-2.6.16/kernel-source-2.6.16_2.6.16.rel-osso26.tar.gz \
+ file://defconfig"
+
+S = "${WORKDIR}/kernel-source-2.6.16-2.6.16.rel"
+
+KERNEL_OUTPUT = "arch/${ARCH}/boot/compressed/${KERNEL_IMAGETYPE}"
+
+inherit kernel
+
+RPROVIDES_kernel-image = "hostap-modules"
+
+COMPATIBLE_MACHINE = "nokia770"
+
+do_configure_prepend() {
+
+ rm -f ${S}/.config || true
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile