aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-09 19:57:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:45 +0100
commit659d0300187accaff393d2b988aef6b58972ed8d (patch)
treef1815c3f80280a899085860b18418677449567bc /meta
parent9c25af5483280c5c753f981504eb373d6e58c7f3 (diff)
downloadopenembedded-core-contrib-659d0300187accaff393d2b988aef6b58972ed8d.tar.gz
neon: build the test suite to verify neon links
Without building a binary it's impossible to tell if a library will link correctly, so build the test suite in do_compile(). Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/neon/neon_0.30.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/neon/neon_0.30.1.bb b/meta/recipes-support/neon/neon_0.30.1.bb
index 9245244eb8..fd170bc0cb 100644
--- a/meta/recipes-support/neon/neon_0.30.1.bb
+++ b/meta/recipes-support/neon/neon_0.30.1.bb
@@ -20,3 +20,7 @@ inherit autotools binconfig-disabled lib_package pkgconfig
EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
EXTRA_OECONF += "--without-gssapi"
+
+do_compile_append() {
+ oe_runmake -C test
+}
href='#n160'>160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222