aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMei Lei <lei.mei@intel.com>2011-04-04 17:17:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-04 17:25:58 +0100
commitcc6763b81fafddcb112a6126373c594e3ec4b140 (patch)
treea97b49c07dd9af87303f68072d5a8d6a39fb9fd4 /meta
parentf4f4efbf3f0b19fdb05ddf48ab48b4f42109a289 (diff)
downloadopenembedded-core-contrib-cc6763b81fafddcb112a6126373c594e3ec4b140.tar.gz
qemuppc: add libqtopengl4 for ppc
Modify some configs for ppc to enable the libqtopengl4 support. This fixes [YOCTO #848] Signed-off-by: Mei Lei <lei.mei@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/machine/qemuppc.conf2
-rw-r--r--meta/recipes-extended/tasks/task-poky-lsb.bb3
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free.inc1
3 files changed, 6 insertions, 0 deletions
diff --git a/meta/conf/machine/qemuppc.conf b/meta/conf/machine/qemuppc.conf
index 83d0841159..bfbcc7f1aa 100644
--- a/meta/conf/machine/qemuppc.conf
+++ b/meta/conf/machine/qemuppc.conf
@@ -4,6 +4,8 @@
TARGET_ARCH = "powerpc"
+PREFERRED_PROVIDER_virtual/libgl = "mesa-xlib"
+
require conf/machine/include/qemu.inc
require conf/machine/include/tune-ppc603e.inc
diff --git a/meta/recipes-extended/tasks/task-poky-lsb.bb b/meta/recipes-extended/tasks/task-poky-lsb.bb
index 7b3c41a85c..6fea613cc0 100644
--- a/meta/recipes-extended/tasks/task-poky-lsb.bb
+++ b/meta/recipes-extended/tasks/task-poky-lsb.bb
@@ -172,6 +172,9 @@ RDEPENDS_task-poky-lsb-graphic-add_qemux86 = "\
RDEPENDS_task-poky-lsb-graphic-add_atom-pc = "\
libqtopengl4 \
"
+RDEPENDS_task-poky-lsb-graphic-add_qemuppc = "\
+ libqtopengl4 \
+"
# mesa-dri
diff --git a/meta/recipes-qt/qt4/qt4-x11-free.inc b/meta/recipes-qt/qt4/qt4-x11-free.inc
index 057a129ecf..306adb9d2e 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free.inc
+++ b/meta/recipes-qt/qt4/qt4-x11-free.inc
@@ -12,6 +12,7 @@ QT_GLFLAGS ?= "-no-opengl"
QT_GLFLAGS_qemux86 = "-opengl"
QT_GLFLAGS_emenlow = "-opengl"
QT_GLFLAGS_atom-pc = "-opengl"
+QT_GLFLAGS_qemuppc = "-opengl"
QT_CONFIG_FLAGS += "-no-xinerama -no-xkb ${QT_GLFLAGS}"
QT_BASE_NAME ?= "qt4"
QT_BASE_LIB ?= "libqt"