aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-10 11:34:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-14 10:23:22 +0100
commit7fb9648f7a055beef9c8a735850b1b51fd23ff1d (patch)
tree53013f00636c6214505a25c56c5e7fdf08b6bcdb /meta
parent03bb12008891cf1a023aaddb6547da6d41d0cab0 (diff)
downloadopenembedded-core-contrib-7fb9648f7a055beef9c8a735850b1b51fd23ff1d.tar.gz
gcc_7.1.bb: disable thumb on armv5t
It results in same link errors like armv4t Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc_7.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_7.1.bb b/meta/recipes-devtools/gcc/gcc_7.1.bb
index 2c618dfb93..ab208e7026 100644
--- a/meta/recipes-devtools/gcc/gcc_7.1.bb
+++ b/meta/recipes-devtools/gcc/gcc_7.1.bb
@@ -1,9 +1,10 @@
require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-target.inc
-# Building with thumb enabled on armv4t fails with
+# Building with thumb enabled on armv4t armv5t fails with
# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
BBCLASSEXTEND = "nativesdk"