aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2017-04-11 10:49:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-11 18:09:21 +0100
commitef94ffee8f11db57ecea398af76dc22576c2068a (patch)
treeb9dddccccb854bff0f39d473213f6eba9f37572b /meta
parent5acad7f33aebfac4c5a3a68778f5860f954904fe (diff)
downloadopenembedded-core-contrib-ef94ffee8f11db57ecea398af76dc22576c2068a.tar.gz
gstreamer1.0-plugins-good: Backport patch for v4l2object videometa
This patch ensures videometa is added to mem2mem decoder output in case the output frames have padding rows/columns Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2object-Also-add-videometa-if-there-is-padding-to.patch35
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.4.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2object-Also-add-videometa-if-there-is-padding-to.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2object-Also-add-videometa-if-there-is-padding-to.patch
new file mode 100644
index 0000000000..2a9a23e15d
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2object-Also-add-videometa-if-there-is-padding-to.patch
@@ -0,0 +1,35 @@
+From 22be02612adc757f6a43cefc6ee65ecaef68f0d9 Mon Sep 17 00:00:00 2001
+From: Carlos Rafael Giani <dv@pseudoterminal.org>
+Date: Thu, 23 Mar 2017 22:13:05 +0100
+Subject: [PATCH] v4l2object: Also add videometa if there is padding to the
+ right and bottom
+
+https://bugzilla.gnome.org/show_bug.cgi?id=780478
+
+Upstream-Status: Backport [1.10.5]
+
+Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
+---
+ sys/v4l2/gstv4l2object.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/sys/v4l2/gstv4l2object.c b/sys/v4l2/gstv4l2object.c
+index 91c8ff0..ed4654e 100644
+--- a/sys/v4l2/gstv4l2object.c
++++ b/sys/v4l2/gstv4l2object.c
+@@ -3070,9 +3070,10 @@ store_info:
+ GST_DEBUG_OBJECT (v4l2object->element, "Got sizeimage %" G_GSIZE_FORMAT,
+ info->size);
+
+- /* to avoid copies we need video meta if top or left padding */
++ /* to avoid copies we need video meta if there is padding */
+ v4l2object->need_video_meta =
+- ((align->padding_top + align->padding_left) != 0);
++ ((align->padding_top + align->padding_left + align->padding_right +
++ align->padding_bottom) != 0);
+
+ /* ... or if stride is non "standard" */
+ if (!standard_stride)
+--
+2.7.4
+
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.4.bb
index fd5369a5c5..57447bffba 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.4.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.4.bb
@@ -10,6 +10,7 @@ SRC_URI = " \
file://avoid-including-sys-poll.h-directly.patch \
file://ensure-valid-sentinel-for-gst_structure_get.patch \
file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
+ file://0001-v4l2object-Also-add-videometa-if-there-is-padding-to.patch \
"
SRC_URI[md5sum] = "cc0cc13cdb07d4237600b6886b81f31d"
SRC_URI[sha256sum] = "8a86c61434a8c44665365bd0b3557a040937d1f44bf69caee4e9ea816ce74d7e"