summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-04-22 00:50:13 +0200
committerAndreas Oberritter <obi@opendreambox.org>2020-07-02 12:17:24 +0200
commit1aa340d8a2080737960552664fd06ecca2f73d33 (patch)
tree09e58a5b0b0c9ced4e40cb353e9227a422720c22 /meta
parent73b865291e239b1e428380d122aecdf6b6325c23 (diff)
downloadopenembedded-core-contrib-1aa340d8a2080737960552664fd06ecca2f73d33.tar.gz
apt-native: use sed to prepare apt.conf.sample
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/apt/apt-native_1.2.31.bb35
-rw-r--r--meta/recipes-devtools/apt/apt/apt.conf.in (renamed from meta/recipes-devtools/apt/files/apt.conf)6
2 files changed, 12 insertions, 29 deletions
diff --git a/meta/recipes-devtools/apt/apt-native_1.2.31.bb b/meta/recipes-devtools/apt/apt-native_1.2.31.bb
index 4680bd5779..80d7a92dbc 100644
--- a/meta/recipes-devtools/apt/apt-native_1.2.31.bb
+++ b/meta/recipes-devtools/apt/apt-native_1.2.31.bb
@@ -11,33 +11,11 @@ SRC_URI += "file://db_linking_hack.patch \
file://no-curl.patch \
file://gcc_4.x_apt-pkg-contrib-strutl.cc-Include-array-header.patch \
file://gcc_4.x_Revert-avoid-changing-the-global-LC_TIME-for-Release.patch \
- file://gcc_4.x_Revert-use-de-localed-std-put_time-instead-rolling-o.patch"
+ file://gcc_4.x_Revert-use-de-localed-std-put_time-instead-rolling-o.patch \
+ file://apt.conf.in \
+"
-python do_install () {
- bb.build.exec_func('do_install_base', d)
- bb.build.exec_func('do_install_config', d)
-}
-
-python do_install_config () {
- indir = os.path.dirname(d.getVar('FILE'))
- infile = open(oe.path.join(indir, 'files', 'apt.conf'), 'r')
- data = infile.read()
- infile.close()
-
- data = d.expand(data)
-
- outdir = oe.path.join(d.getVar('D'), d.getVar('sysconfdir'), 'apt')
- if not os.path.exists(outdir):
- os.makedirs(outdir)
-
- outpath = oe.path.join(outdir, 'apt.conf.sample')
- if not os.path.exists(outpath):
- outfile = open(outpath, 'w')
- outfile.write(data)
- outfile.close()
-}
-
-do_install_base () {
+do_install() {
install -d ${D}${bindir}
install -m 0755 bin/apt-cdrom ${D}${bindir}/
install -m 0755 bin/apt-get ${D}${bindir}/
@@ -75,4 +53,9 @@ do_install_base () {
do
install -m 0644 $h ${D}${includedir}/apt-pkg
done
+
+ sed -e "s,@STAGING_DIR_NATIVE@,${STAGING_DIR_NATIVE},g" \
+ -e "s,@STAGING_BINDIR_NATIVE@,${STAGING_BINDIR_NATIVE},g" \
+ -e "s,@STAGING_LIBDIR@,${STAGING_LIBDIR},g" \
+ < ${WORKDIR}/apt.conf.in > ${D}${sysconfdir}/apt/apt.conf.sample
}
diff --git a/meta/recipes-devtools/apt/files/apt.conf b/meta/recipes-devtools/apt/apt/apt.conf.in
index a6fe97d860..b8863a2b00 100644
--- a/meta/recipes-devtools/apt/files/apt.conf
+++ b/meta/recipes-devtools/apt/apt/apt.conf.in
@@ -1,4 +1,4 @@
-Dir "${STAGING_DIR_NATIVE}/"
+Dir "@STAGING_DIR_NATIVE@/"
{
State "var/lib/apt/"
{
@@ -11,9 +11,9 @@ Dir "${STAGING_DIR_NATIVE}/"
pkgcache "";
srcpkgcache "";
};
- Bin "${STAGING_BINDIR_NATIVE}/"
+ Bin "@STAGING_BINDIR_NATIVE@/"
{
- methods "${STAGING_LIBDIR}/apt/methods/";
+ methods "@STAGING_LIBDIR@/apt/methods/";
gzip "/bin/gzip";
dpkg "dpkg";
dpkg-source "dpkg-source";