aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-08-16 21:43:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-20 11:59:44 +0100
commitbdc9e773c240716c2e2a60ca5d4313cfaa6188b1 (patch)
tree31c9fd1c89370ec5adab50ea3ab1dc606c0e3924 /meta
parentd916de84060f41e3a2e98a695b48d0ea52e9bfd9 (diff)
downloadopenembedded-core-contrib-bdc9e773c240716c2e2a60ca5d4313cfaa6188b1.tar.gz
openssl: consolidate target name mapping rules
Merge duplicates + minor reformatting (no functional changes). Note that the openssl 1.1 recipe still needs to be updated to handle MIPS Release 6 ISA targets (e.g. linux-mipsisa32r6, etc). Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2p.bb7
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.0i.bb39
2 files changed, 8 insertions, 38 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
index 5d419772f9..5a2593c0ae 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2p.bb
@@ -164,7 +164,7 @@ do_configure () {
linux-mips*)
target=debian-mips
;;
- linux-microblaze*|linux-nios2*|linux-gnu*ilp32**)
+ linux-microblaze* | linux-nios2* | linux-gnu*ilp32**)
target=linux-generic32
;;
linux-powerpc)
@@ -179,10 +179,7 @@ do_configure () {
linux-riscv64)
target=linux-generic64
;;
- linux-supersparc)
- target=linux-sparcv8
- ;;
- linux-sparc)
+ linux-sparc | linux-supersparc)
target=linux-sparcv8
;;
esac
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
index 7929d81b45..8a8d928f5a 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb
@@ -51,28 +51,13 @@ do_configure () {
esac
target="$os-${HOST_ARCH}"
case $target in
- linux-arm)
- target=linux-armv4
- ;;
- linux-armeb)
+ linux-arm*)
target=linux-armv4
;;
linux-aarch64*)
target=linux-aarch64
;;
- linux-sh3)
- target=linux-generic32
- ;;
- linux-sh4)
- target=linux-generic32
- ;;
- linux-i486)
- target=linux-elf
- ;;
- linux-i586 | linux-viac3)
- target=linux-elf
- ;;
- linux-i686)
+ linux-i?86 | linux-viac3)
target=linux-elf
;;
linux-gnux32-x86_64 | linux-muslx32-x86_64 )
@@ -81,23 +66,17 @@ do_configure () {
linux-gnu64-x86_64)
target=linux-x86_64
;;
- linux-mips)
+ linux-mips | linux-mipsel)
# specifying TARGET_CC_ARCH prevents openssl from (incorrectly) adding target architecture flags
target="linux-mips32 ${TARGET_CC_ARCH}"
;;
- linux-mipsel)
- target="linux-mips32 ${TARGET_CC_ARCH}"
- ;;
linux-gnun32-mips*)
target=linux-mips64
;;
- linux-*-mips64 | linux-mips64)
- target=linux64-mips64
- ;;
- linux-*-mips64el | linux-mips64el)
+ linux-*-mips64 | linux-mips64 | linux-*-mips64el | linux-mips64el)
target=linux64-mips64
;;
- linux-microblaze*|linux-nios2*)
+ linux-microblaze* | linux-nios2* | linux-sh3 | linux-sh4)
target=linux-generic32
;;
linux-powerpc)
@@ -112,15 +91,9 @@ do_configure () {
linux-riscv64)
target=linux-generic64
;;
- linux-supersparc)
- target=linux-sparcv9
- ;;
- linux-sparc)
+ linux-sparc | linux-supersparc)
target=linux-sparcv9
;;
- darwin-i386)
- target=darwin-i386-cc
- ;;
esac
useprefix=${prefix}