aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-15 21:12:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-16 22:38:20 +0100
commitb0783b713e0ad766797d20e0d1f3187effb08a71 (patch)
tree1ec56522793c34500d4b3199a18eee7240702b66 /meta
parent45ff20f325a51fe0ed12d58160c08e04781ce341 (diff)
downloadopenembedded-core-contrib-b0783b713e0ad766797d20e0d1f3187effb08a71.tar.gz
llvm: Update to 6.0.1
Drop upstreamed patch Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/llvm/llvm/0001-Disable-generating-a-native-llvm-config.patch41
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb5
2 files changed, 2 insertions, 44 deletions
diff --git a/meta/recipes-devtools/llvm/llvm/0001-Disable-generating-a-native-llvm-config.patch b/meta/recipes-devtools/llvm/llvm/0001-Disable-generating-a-native-llvm-config.patch
deleted file mode 100644
index 2809e4c594..0000000000
--- a/meta/recipes-devtools/llvm/llvm/0001-Disable-generating-a-native-llvm-config.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 7f7743ce233fcd735ec580c75270413493658aa6 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 Apr 2018 18:08:31 -0700
-Subject: [PATCH] Disable generating a native llvm-config
-
-OpenEmbedded already builds this as part of llvm-native
-
-Upstream-Status: Inappropriate [OE-Specific]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tools/llvm-config/CMakeLists.txt | 16 ----------------
- 1 file changed, 16 deletions(-)
-
-diff --git a/tools/llvm-config/CMakeLists.txt b/tools/llvm-config/CMakeLists.txt
-index 25f99cec978..c45e9b642a8 100644
---- a/tools/llvm-config/CMakeLists.txt
-+++ b/tools/llvm-config/CMakeLists.txt
-@@ -63,19 +63,3 @@ endif()
-
- # Add the dependency on the generation step.
- add_file_dependencies(${CMAKE_CURRENT_SOURCE_DIR}/llvm-config.cpp ${BUILDVARIABLES_OBJPATH})
--
--if(CMAKE_CROSSCOMPILING)
-- set(${project}_LLVM_CONFIG_EXE "${LLVM_NATIVE_BUILD}/bin/llvm-config")
-- set(${project}_LLVM_CONFIG_EXE ${${project}_LLVM_CONFIG_EXE} PARENT_SCOPE)
--
-- add_custom_command(OUTPUT "${${project}_LLVM_CONFIG_EXE}"
-- COMMAND ${CMAKE_COMMAND} --build . --target llvm-config --config $<CONFIGURATION>
-- DEPENDS ${LLVM_NATIVE_BUILD}/CMakeCache.txt
-- WORKING_DIRECTORY ${LLVM_NATIVE_BUILD}
-- COMMENT "Building native llvm-config..."
-- USES_TERMINAL)
-- add_custom_target(${project}NativeLLVMConfig DEPENDS ${${project}_LLVM_CONFIG_EXE})
-- add_dependencies(${project}NativeLLVMConfig CONFIGURE_LLVM_NATIVE)
--
-- add_dependencies(llvm-config ${project}NativeLLVMConfig)
--endif(CMAKE_CROSSCOMPILING)
---
-2.17.0
-
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index cb3bba6fab..bb83012231 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -19,14 +19,13 @@ PROVIDES += "llvm${PV}"
LLVM_RELEASE = "${PV}"
LLVM_DIR = "llvm${LLVM_RELEASE}"
-SRCREV = "089d4c0c490687db6c75f1d074e99c4d42936a50"
+SRCREV = "5136df4d089a086b70d452160ad5451861269498"
PV = "6.0"
BRANCH = "release_60"
-PATCH_VERSION = "0"
+PATCH_VERSION = "1"
SRC_URI = "git://github.com/llvm-mirror/llvm.git;branch=${BRANCH};protocol=http \
file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
file://0002-llvm-allow-env-override-of-exe-path.patch \
- file://0001-Disable-generating-a-native-llvm-config.patch \
"
UPSTREAM_CHECK_COMMITS = "1"
S = "${WORKDIR}/git"