aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2018-10-05 16:27:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-09 12:02:41 +0100
commit631e7bb7d02ca9cb9cb66e6b8395b197525cda55 (patch)
tree4492f716cba874902805cd1bbdd06526dbfeee6a /meta
parent67bc0b3babd922c800a03c1370d6d33a75f273c1 (diff)
downloadopenembedded-core-contrib-631e7bb7d02ca9cb9cb66e6b8395b197525cda55.tar.gz
opkg-utils: Add support for pigz
Support explicit use of pigz when compressing the package contents by setting: OPKGBUILDCMD = "opkg-build -Z pigz" Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/pigz.patch51
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/pigz.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/pigz.patch
new file mode 100644
index 0000000000..dd433e8eb9
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/pigz.patch
@@ -0,0 +1,51 @@
+From ab1436927b47badcd219a5f075dfc848020e061d Mon Sep 17 00:00:00 2001
+From: Mike Crowe <mac@mcrowe.com>
+Date: Thu, 4 Oct 2018 17:54:19 +0100
+Subject: [opkg-utils PATCH] opkg-build: Add support for explicit use of pigz
+To: opkg-devel@googlegroups.com,
+ yocto@yoctoproject.org
+
+oe-core has stopped[1] installing pigz as gzip. This means that in
+order to persuade opkg-build to use pigz it must be specified
+explicitly. Let's teach opkg-build to deal with being passed pigz as a
+compressor.
+
+We can't combine the check for whether -T is required with the one for
+gzip because opkg-build needs to call $compressor and gzip separately
+to construct the package.
+
+[1] http://lists.openembedded.org/pipermail/openembedded-commits/2018-February/218767.html
+
+Upstream-Status: Submitted [opkg-devel@googlegroups.com https://groups.google.com/forum/#!topic/opkg-devel/E0WVOhjK61w]
+Signed-off-by: Mike Crowe <mac@mcrowe.com>
+---
+ opkg-build | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/opkg-build b/opkg-build
+index 93a7956..f8403ea 100755
+--- a/opkg-build
++++ b/opkg-build
+@@ -170,7 +170,7 @@ fi
+
+ compressor_ext() {
+ case $1 in
+- gzip)
++ gzip|pigz)
+ echo gz
+ ;;
+ bzip2)
+@@ -232,6 +232,10 @@ if [ $compressor = "gzip" ] ; then
+ compressorargs=$zipargs
+ elif [ $compressor = "xz" ] ; then
+ compressorargs="--threads 0"
++elif [ $compressor = "pigz" ] ; then
++ if $compressor --help 2>&1 | grep -- "-T" > /dev/null; then
++ compressorargs="-9nT"
++ fi
+ fi
+
+ tsortargs=
+--
+2.11.0
+
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
index 0487c5f305..cb3775d9c9 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
@@ -12,6 +12,7 @@ SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV
file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \
file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \
file://threaded-xz.patch \
+ file://pigz.patch \
"
SRC_URI_append_class-native = " file://tar_ignore_error.patch"
UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"