aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-04-10 08:58:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-11 08:50:53 +0100
commit3398552663e1e18aaf352d682a77a8ad3af94e5a (patch)
tree24f7322e714270e5fb7f843d009c01f1832f20ff /meta
parent82ae62f28dd2d5fb2fb261478ac6161315ac6c38 (diff)
downloadopenembedded-core-contrib-3398552663e1e18aaf352d682a77a8ad3af94e5a.tar.gz
gnu-efi: copy header files for x32 build
Gnu-efi needs to be build for 64bit since it is a boot time tool. It needs these 2 headers to be in 64 bit versions, we can use the existing 32bit ones as there is not really any difference. [YOCTO #11051] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi_3.0.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.5.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.5.bb
index f46381d5f1..6f235b7455 100644
--- a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.5.bb
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.5.bb
@@ -24,6 +24,11 @@ SRC_URI[sha256sum] = "bd8fcd5914f18fc0e4ba948ab03b00013e528504f529c60739b748f6ef
COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
COMPATIBLE_HOST_armv4 = 'null'
+do_configure_linux-gnux32_prepend() {
+ cp ${STAGING_INCDIR}/gnu/stubs-x32.h ${STAGING_INCDIR}/gnu/stubs-64.h
+ cp ${STAGING_INCDIR}/bits/long-double-32.h ${STAGING_INCDIR}/bits/long-double-64.h
+}
+
def gnu_efi_arch(d):
import re
tarch = d.getVar("TARGET_ARCH")