summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2012-12-03 18:23:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:35 +0000
commitef2951d052f18be9c5391dce438f5c3fafda3cd5 (patch)
tree57d76ffcdcade16e364680451f9ed5579ad8d4f9 /meta
parentc5f14ef7797394bcee1b0e295cc2dac4b62e55e2 (diff)
downloadopenembedded-core-contrib-ef2951d052f18be9c5391dce438f5c3fafda3cd5.tar.gz
libassuan: add pkgconfig support
Add pkgconfig support to libassuan. [YOCTO #2453] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch59
-rw-r--r--meta/recipes-support/libassuan/libassuan_2.0.3.bb5
2 files changed, 62 insertions, 2 deletions
diff --git a/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch b/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch
new file mode 100644
index 0000000000..ba332527f1
--- /dev/null
+++ b/meta/recipes-support/libassuan/files/libassuan-add-pkgconfig-support.patch
@@ -0,0 +1,59 @@
+Upstream-Status: Rejected
+
+Add pkgconfig support to libassuan.
+This patch is rejected by upstream for the reason below:
+They think pkgconfig adds no portability and maintaining them is not worthwhile.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+Index: Makefile.am
+==============================================================
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -21,11 +21,14 @@
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = assuan.pc
++
+ EXTRA_DIST = config.rpath autogen.sh README.GIT \
+ ChangeLog-2011 doc/ChangeLog-2011 src/ChangeLog-2011 \
+ tests/ChangeLog-2011 contrib/ChangeLog-2011 \
+ build-aux/gitlog-to-changelog build-aux/git-log-footer \
+- build-aux/git-log-fix
++ build-aux/git-log-fix assuan.pc.in
+
+ SUBDIRS = m4 src doc tests
+
+Index: assuan.pc.in
+==============================================================
+--- /dev/null
++++ b/assuan.pc.in
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libassuan
++Description: IPC library used by GnuPG and GPGME
++Requires:
++Version: @VERSION@
++Libs: -L${libdir} -lassuan
++Libs.private: -lgpg-error
++Cflags: -I${includedir}
+Index: configure.ac
+==============================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -380,5 +380,5 @@ AC_CONFIG_FILES([doc/Makefile])
+ AC_CONFIG_FILES([tests/Makefile])
+ AC_CONFIG_FILES([src/libassuan-config], [chmod +x src/libassuan-config])
+ AC_CONFIG_FILES([src/versioninfo.rc])
+-
++AC_CONFIG_FILES([assuan.pc])
+ AC_OUTPUT
+--
+1.7.5.4
+
diff --git a/meta/recipes-support/libassuan/libassuan_2.0.3.bb b/meta/recipes-support/libassuan/libassuan_2.0.3.bb
index 2a8963ec0a..f0d7c9f4b6 100644
--- a/meta/recipes-support/libassuan/libassuan_2.0.3.bb
+++ b/meta/recipes-support/libassuan/libassuan_2.0.3.bb
@@ -10,9 +10,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
DEPENDS = "libgpg-error"
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libassuan/libassuan-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libassuan/libassuan-${PV}.tar.bz2 \
+ file://libassuan-add-pkgconfig-support.patch"
SRC_URI[md5sum] = "179d1918325fdb928c7bd90b8a514fc7"
SRC_URI[sha256sum] = "bad5682374c76bcc0abb1a7a34c9557af6874a477500748e64a7d3def79cac1b"
-inherit autotools binconfig
+inherit autotools binconfig pkgconfig