summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNick D'Ademo <nickdademo@gmail.com>2013-11-27 21:20:01 +1100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-27 11:57:38 +0000
commite840f526e7223c9d393aab818c7a5a446b89c503 (patch)
treee7a47f57c645bd5410ada08b6432a42b9c29c43b /meta
parent47e7b47def5b06a1d825bf0883409510cb4da36f (diff)
downloadopenembedded-core-contrib-e840f526e7223c9d393aab818c7a5a446b89c503.tar.gz
tcl: fix version string and make recipe multilib build compatible
Explicitly set libdir in EXTRA_OECONF so that the correct library folder is generated in a multilib build. The version string (VER) has been changed to 8.6.1 and the library paths have been updated accordingly so that the related tk recipe can correctly detect tcl (this search is done using the tclConfig.sh script which contains the tcl version number). Signed-off-by: Nick D'Ademo <nickdademo@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.1.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
index f40475d2b5..10186c43d6 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
@@ -28,13 +28,13 @@ SRC_URI_class-native = "${BASE_SRC_URI}"
S = "${WORKDIR}/tcl${PV}/unix"
-VER = "8.6"
+VER = "8.6.1"
inherit autotools
DEPENDS_class-native = ""
-EXTRA_OECONF = "--enable-threads --disable-rpath"
+EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}"
do_configure() {
( cd ${S}; gnu-configize )
@@ -67,8 +67,8 @@ tcl_sysroot_preprocess () {
}
PACKAGES =+ "tcl-lib"
-FILES_tcl-lib = "${libdir}/libtcl${VER}.so.*"
-FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8"
+FILES_tcl-lib = "${libdir}/libtcl8.6.so.*"
+FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8"
FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh"
# isn't getting picked up by shlibs code