summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-30 17:57:50 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-30 18:02:36 +0100
commitced8cb0809f1881d2d187b647b72a39df6a14559 (patch)
tree08a1c232eb456999a9a05c1f6352547a2bd29c16 /meta
parentbb1b3cfd531a74f98201e70706c3ddfd82481265 (diff)
downloadopenembedded-core-contrib-ced8cb0809f1881d2d187b647b72a39df6a14559.tar.gz
signgp: Add licence info from OE.dev
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/x-load/files/signGP.c35
-rw-r--r--meta/recipes-bsp/x-load/signgp-native.bb4
2 files changed, 37 insertions, 2 deletions
diff --git a/meta/recipes-bsp/x-load/files/signGP.c b/meta/recipes-bsp/x-load/files/signGP.c
index 0e8ed07f52..9325064013 100644
--- a/meta/recipes-bsp/x-load/files/signGP.c
+++ b/meta/recipes-bsp/x-load/files/signGP.c
@@ -1,3 +1,38 @@
+/*
+ * Copyright (C) 2010 Texas Instruments Incorporated - http://www.ti.com/
+ *
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ *
+ * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the
+ * distribution.
+ *
+ * Neither the name of Texas Instruments Incorporated nor the names of
+ * its contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ *
+*/
+
+
//
// signGP.c
// Read the x-load.bin file and write out the x-load.bin.ift file.
diff --git a/meta/recipes-bsp/x-load/signgp-native.bb b/meta/recipes-bsp/x-load/signgp-native.bb
index 7eabb07bce..ae8c8f9dcb 100644
--- a/meta/recipes-bsp/x-load/signgp-native.bb
+++ b/meta/recipes-bsp/x-load/signgp-native.bb
@@ -1,11 +1,11 @@
-LICENSE = "unknown"
+LICENSE = "BSD"
DESCRIPTION = "Tool to sign omap3 x-loader images"
inherit native
SRC_URI = "file://signGP.c"
do_compile() {
- ${CC} ${WORKDIR}/signGP.c -o signGP
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/signGP.c -o signGP
}
do_install() {