summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-29 15:33:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:32 +0000
commitbb3abe241ae9d7e62e084cde383ebe1c6b95d825 (patch)
tree34686cefda1195483bab2e29c4cc0b68ac3b0807 /meta
parent7dbe5004380b97949a7910706364ba57c6c52a33 (diff)
downloadopenembedded-core-contrib-bb3abe241ae9d7e62e084cde383ebe1c6b95d825.tar.gz
python-smartpm: fix package metadata not being read from rpm-md feeds
The XML indexes in rpm-md were being parsed incorrectly leading to the package metadata (e.g. dependencies) not being read. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch26
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch b/meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch
new file mode 100644
index 0000000000..97cecc124d
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-rpm-md-parse.patch
@@ -0,0 +1,26 @@
+backends/rpm: fix parsing of rpm-md metadata
+
+If assertions are disabled then the queue.pop() wasn't being executed,
+leading to requires, recommends etc. not being read properly.
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/smart/backends/rpm/metadata.py b/smart/backends/rpm/metadata.py
+index 2c54f39..dc9df22 100644
+--- a/smart/backends/rpm/metadata.py
++++ b/smart/backends/rpm/metadata.py
+@@ -188,7 +188,8 @@ class RPMMetaDataLoader(Loader):
+
+ elif event == "end":
+
+- assert queue.pop() is elem
++ popped = queue.pop()
++ assert popped is elem
+
+ if skip:
+ if tag == skip:
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index ff153a77d0..2d0f7cd641 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -11,7 +11,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
DEPENDS = "python rpm"
-PR = "r1"
+PR = "r2"
SRCNAME = "smart"
SRC_URI = "\
@@ -19,6 +19,7 @@ SRC_URI = "\
file://smartpm-rpm5-nodig.patch \
file://smart-rpm-root.patch \
file://smart-recommends.patch \
+ file://smart-rpm-md-parse.patch \
"
SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"