summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-17 23:03:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-04 11:34:22 +0100
commit85d8362e0c443f11fe8d3fd0fba55d1bd4983613 (patch)
tree486f176b9c9be22974186fcecc0ad568f3669950 /meta
parent68189d7c372a861767b5db90376d61e165f9771b (diff)
downloadopenembedded-core-contrib-85d8362e0c443f11fe8d3fd0fba55d1bd4983613.tar.gz
Improve handling of 'all' architecture recipes and their interaction with sstate
* Jansa: rebased on current master, added nocompiler patch also to font-alias, dropped allarch from linux-firmware, gnome-icon-theme, hal-info as those are checking compiler (ie in intltool check) and better to build them as default arch instead of rebuilding after every machine change. * this is also part of [BUGID# 1075] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb8
-rw-r--r--meta/recipes-gnome/gnome/gnome-common_2.28.0.bb7
-rw-r--r--meta/recipes-gnome/gnome/gnome-icon-theme_2.31.0.bb3
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb5
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb5
-rw-r--r--meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb5
-rw-r--r--meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb6
-rw-r--r--meta/recipes-graphics/xorg-font/encodings/nocompiler.patch31
-rw-r--r--meta/recipes-graphics/xorg-font/encodings_1.0.4.bb8
-rw-r--r--meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb5
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc4
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb2
12 files changed, 58 insertions, 31 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
index 94231e0af6..8e0b215de3 100644
--- a/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
+++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
@@ -9,15 +9,16 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
AUTHOR = "Thomas Hood"
HOMEPAGE = "http://packages.debian.org/resolvconf"
-DEPENDS = "bash"
RDEPENDS_${PN} = "bash"
-PR = "r0"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
SRC_URI[md5sum] = "59b20258bb8a3c25b8c4083fc0279547"
SRC_URI[sha256sum] = "37691677cea24da66d6664c98668b5f16667c0133f17feb166f246ee923ad756"
+inherit allarch
+
do_compile () {
:
}
@@ -31,6 +32,3 @@ do_install () {
install -m 0644 README ${D}${docdir}/${P}/
install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
}
-
-PACKAGE_ARCH = "all"
-
diff --git a/meta/recipes-gnome/gnome/gnome-common_2.28.0.bb b/meta/recipes-gnome/gnome/gnome-common_2.28.0.bb
index 570c45a703..8936dbd8b9 100644
--- a/meta/recipes-gnome/gnome/gnome-common_2.28.0.bb
+++ b/meta/recipes-gnome/gnome/gnome-common_2.28.0.bb
@@ -6,11 +6,8 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SECTION = "x11/gnome"
-PR = "r0"
-inherit gnome
-
-# all isn't appropriate since STAGING_DATADIR is target specific
-# PACKAGE_ARCH="all"
+PR = "r1"
+inherit gnome allarch
# The omf.make file failed if scrollkeeper doesn't happen to be
# installed
diff --git a/meta/recipes-gnome/gnome/gnome-icon-theme_2.31.0.bb b/meta/recipes-gnome/gnome/gnome-icon-theme_2.31.0.bb
index 55868abf7f..587ac40a1e 100644
--- a/meta/recipes-gnome/gnome/gnome-icon-theme_2.31.0.bb
+++ b/meta/recipes-gnome/gnome/gnome-icon-theme_2.31.0.bb
@@ -22,6 +22,3 @@ SRC_URI[sha256sum] = "ea7e05b77ead159379392b3b275ca0c9cbacd7d936014e447cc7c5e27a
EXTRA_OECONF = "--disable-hicolor-check --with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
inherit autotools
-
-# We can't do this until the output is shared into all target sysroots
-#PACKAGE_ARCH = "all"
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
index 19bb69c1f3..b0a8242d82 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
@@ -8,11 +8,12 @@ BUGTRACKER = "https://bugzilla.redhat.com/"
SECTION = "x11/fonts"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PACKAGE_ARCH = "all"
RDEPENDS_${PN} = "fontconfig-utils"
-PR = "r1"
+PR = "r2"
PE = "1"
+inherit allarch
+
SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \
file://30-liberation-aliases.conf"
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
index 4882cc7be3..5193fda3af 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
@@ -8,10 +8,9 @@ BUGTRACKER = "https://bugzilla.redhat.com/"
SECTION = "x11/fonts"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PACKAGE_ARCH = "all"
RDEPENDS_${PN} = "fontconfig-utils"
PE = "1"
-PR = "r1"
+PR = "r2"
FONTREV = "0.20100721"
SRC_URI = "https://fedorahosted.org/releases/l/i/${BPN}/${BPN}-${PV}.${FONTREV}.tar.gz \
@@ -19,6 +18,8 @@ SRC_URI = "https://fedorahosted.org/releases/l/i/${BPN}/${BPN}-${PV}.${FONTREV}.
S = ${WORKDIR}/${BPN}-${PV}.${FONTREV}
+inherit allarch
+
do_install () {
install -d ${D}${datadir}/fonts/ttf/
for i in *.ttf; do
diff --git a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
index 3294b40ae0..682184a95d 100644
--- a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
+++ b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -7,10 +7,11 @@ but is visibly different than normal and bold, and reasonably pleasing."
SECTION = "x11/fonts"
LICENSE = "Bitstream_Vera"
LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
-PACKAGE_ARCH = "all"
-PR = "r4"
+PR = "r5"
RDEPENDS_${PN} = "fontconfig-utils"
+inherit allarch
+
SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
do_install () {
diff --git a/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb b/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
index 002cc1569b..824c295a96 100644
--- a/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
+++ b/meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
SECTION = "x11/base"
-PR="r3"
+PR = "r4"
SRC_URI = "http://matchbox-project.org/sources/utils/xcursor-transparent-theme-${PV}.tar.gz \
file://use-relative-symlinks.patch \
@@ -16,6 +16,4 @@ SRC_URI[md5sum] = "7b0c623049d4aab20600d6473f8aab23"
SRC_URI[sha256sum] = "b26adf2d503d01299718390ae39dab4691a67220de09423be0364e9a060bf7e4"
FILES_${PN} = "${datadir}/icons/xcursor-transparent/cursors/*"
-inherit autotools
-
-PACKAGE_ARCH = "all"
+inherit autotools allarch
diff --git a/meta/recipes-graphics/xorg-font/encodings/nocompiler.patch b/meta/recipes-graphics/xorg-font/encodings/nocompiler.patch
new file mode 100644
index 0000000000..1cddd102f5
--- /dev/null
+++ b/meta/recipes-graphics/xorg-font/encodings/nocompiler.patch
@@ -0,0 +1,31 @@
+XORG_DEFAULT_OPTIONS pulls in the following dependency chains:
+
+XORG_CWARNFLAGS -> AC_PROG_CC_C99
+XORG_STRICT_OPTION -> AC_PROG_CC_C99, XORG_CWARNFLAGS
+XORG_MANPAGE_SECTIONS -> AC_CANONICAL_HOST -> Checks host
+
+each of which triggers the use of the host compiler. As an "all"
+architecture package, it shouldn't need a compiler (and doesn't).
+
+RP 17/5/2011
+
+Index: encodings-1.0.4/configure.ac
+===================================================================
+--- encodings-1.0.4.orig/configure.ac 2011-05-17 23:36:19.505095876 +0100
++++ encodings-1.0.4/configure.ac 2011-05-17 23:54:14.935096128 +0100
+@@ -4,12 +4,12 @@
+ AM_INIT_AUTOMAKE([foreign dist-bzip2])
+ AM_MAINTAINER_MODE
+
+-# Require xorg-macros: XORG_DEFAULT_OPTIONS
+ m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+ XORG_MACROS_VERSION(1.3)
+-XORG_DEFAULT_OPTIONS
+-
++XORG_RELEASE_VERSION
++XORG_CHANGELOG
++XORG_INSTALL
+ AC_PROG_INSTALL
+
+ # Require X.Org's font util macros 1.2 or later
diff --git a/meta/recipes-graphics/xorg-font/encodings_1.0.4.bb b/meta/recipes-graphics/xorg-font/encodings_1.0.4.bb
index 1345134432..cf7b3e3609 100644
--- a/meta/recipes-graphics/xorg-font/encodings_1.0.4.bb
+++ b/meta/recipes-graphics/xorg-font/encodings_1.0.4.bb
@@ -7,13 +7,15 @@ require xorg-font-common.inc
LICENSE = "PD"
LIC_FILES_CHKSUM = "file://COPYING;md5=9da93f2daf2d5572faa2bfaf0dbd9e76"
PE = "1"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEPENDS = "mkfontscale-native font-util-native"
-EXTRA_OECONF += "--with-encodingsdir=${datadir}/fonts/X11/encodings"
+SRC_URI += "file://nocompiler.patch"
+
+inherit allarch
-PACKAGE_ARCH = "all"
+EXTRA_OECONF += "--with-encodingsdir=${datadir}/fonts/X11/encodings"
SRC_URI[md5sum] = "0f2d6546d514c5cc4ecf78a60657a5c1"
SRC_URI[sha256sum] = "ced6312988a45d23812c2ac708b4595f63fd7a49c4dcd9f66bdcd50d1057d539"
diff --git a/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb b/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
index f1e8648e08..b1a65e7b85 100644
--- a/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
+++ b/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
@@ -13,10 +13,11 @@ LIC_FILES_CHKSUM = "file://../misc/fonts.alias;md5=bbe8d3c0e4e74af96e3ac393985c4
SRC_URI = "file://misc"
PE = "1"
-PR = "r0"
+PR = "r1"
+
+inherit allarch
PACKAGES = "${PN}"
-PACKAGE_ARCH = "all"
FILES_${PN} = "${libdir}/X11/ ${datadir}/fonts/X11/"
do_install() {
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc b/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
index 0eff9dd7ae..75e029c0e8 100644
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
@@ -8,12 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2"
SECTION = "x11"
DEPENDS = ""
-inherit autotools pkgconfig
+inherit autotools pkgconfig allarch
FILES_${PN} += "${datadir}"
-PACKAGE_ARCH = "all"
-
EXTRA_OECONF += "--with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
#explictly setting "Sato" as default icon theme to avoid icon missing due to
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
index e69481de3a..54e46277ff 100644
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
@@ -2,6 +2,8 @@ require sato-icon-theme.inc
DEPENDS += "icon-naming-utils-native"
+PR = "r1"
+
SRC_URI = "http://pokylinux.org/releases/sato/${BPN}-${PV}.tar.gz \
file://iconpath-option.patch"