summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-11-28 17:38:12 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:33 +0000
commit81f8972323a0a89e67f5cc4be247bc8e1b637cc4 (patch)
treee347724393917700eb09469b72d1ae0eaa4104dd /meta
parent0564f7bbe8e06868e107b70d5abbf3dd6c113bad (diff)
downloadopenembedded-core-contrib-81f8972323a0a89e67f5cc4be247bc8e1b637cc4.tar.gz
python-smartpm: Fix incorrect comparison arguments
Built-in provides were not being compared properly within smart. This was caused by an incorrect argument to the match function. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-metadata-match.patch28
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-metadata-match.patch b/meta/recipes-devtools/python/python-smartpm/smart-metadata-match.patch
new file mode 100644
index 0000000000..d06f416605
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-metadata-match.patch
@@ -0,0 +1,28 @@
+smart - backends/rmp/metadata.py: Fix incorrect call to the match function
+
+The match function should take three parameters, name, comparison, version...
+The original code was passing it a reference to the object holding the data
+instead, which caused the comparison in match to always fail.
+
+Upstream-Status: Pending
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+--- a/smart/backends/rpm/metadata.py
++++ b/smart/backends/rpm/metadata.py
+@@ -332,13 +332,13 @@
+ reqargs = [x for x in reqdict
+ if not ((x[2] is None or "=" in x[2]) and
+ (RPMProvides, x[1], x[3]) in prvdict or
+- system_provides.match(*x[:3]))]
++ system_provides.match(x[1], x[2], x[3]))]
+ reqargs = collapse_libc_requires(reqargs)
+
+ recargs = [x for x in recdict
+ if not ((x[2] is None or "=" in x[2]) and
+ (RPMProvides, x[1], x[3]) in prvdict or
+- system_provides.match(*x[:3]))]
++ system_provides.match(x[1], x[2], x[3]))]
+
+ prvargs = prvdict.keys()
+ cnfargs = cnfdict.keys()
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 4694d517aa..bbaa530c4a 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -11,7 +11,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
DEPENDS = "python rpm"
-PR = "r2"
+PR = "r3"
SRCNAME = "smart"
SRC_URI = "\
@@ -23,6 +23,7 @@ SRC_URI = "\
file://smart-dflags.patch \
file://smart-rpm-md-parse.patch \
file://smart-tmpdir.patch \
+ file://smart-metadata-match.patch \
"
SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"