summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2013-11-26 13:17:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-27 12:05:43 +0000
commit79b0979ecd33ce15563354c90d8bcc857ddf95ad (patch)
treeb2b12073333f46a85e31217e211099e5ec23491a /meta
parente16b6bab8d5286cdf58d808ef4c195127d69a8c8 (diff)
downloadopenembedded-core-contrib-79b0979ecd33ce15563354c90d8bcc857ddf95ad.tar.gz
elfutils: fix the condition check before remove eu-objdump
"grep -q" does not write anything to standard output, the result is same as a empty string, The second test becomes [!""] which is a fixed true value Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.155.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.155.bb b/meta/recipes-devtools/elfutils/elfutils_0.155.bb
index 594dfb09ea..14eac26d83 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.155.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.155.bb
@@ -48,7 +48,7 @@ do_configure_prepend() {
}
do_install_append() {
- if [ "${TARGET_ARCH}" != "x86_64" ] && [ ! `echo "${TARGET_ARCH}"|grep -q 'i.86'` ];then
+ if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
rm ${D}${bindir}/eu-objdump
fi
}