summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-09-26 17:43:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-26 17:48:41 +0100
commit2c1e147e61875054039ff08c36657c68c73037ee (patch)
treee4e273c1663a2d28339540d1ba9f0b32a2ee81e7 /meta
parent4e2b86787ed7a44ad88aa1431207d049c2cb444a (diff)
downloadopenembedded-core-contrib-2c1e147e61875054039ff08c36657c68c73037ee.tar.gz
eglinfo: drop machine-specific configuration from oe-core
eglinfo.inc has some board-specific EGLINFO_DEVICE settings but is missing the dependencies. Maintaining them for all supported devices in oe-core isn't scalable and this is trivially supported though a bbappend in each BSP layer. This was also causing problems compiling eglinfo on meta-yocto-bsp's beagleboard machine as the EGLINFO_DEVICE setting for beagleboard was telling it to use the closed GPU drivers, which are not supported in meta-yocto-bsp. [ YOCTO #5224 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/eglinfo/eglinfo-fb_1.0.bb5
-rw-r--r--meta/recipes-graphics/eglinfo/eglinfo.inc11
2 files changed, 3 insertions, 13 deletions
diff --git a/meta/recipes-graphics/eglinfo/eglinfo-fb_1.0.bb b/meta/recipes-graphics/eglinfo/eglinfo-fb_1.0.bb
index 65b265fcb7..455d31e872 100644
--- a/meta/recipes-graphics/eglinfo/eglinfo-fb_1.0.bb
+++ b/meta/recipes-graphics/eglinfo/eglinfo-fb_1.0.bb
@@ -1,11 +1,6 @@
EGLINFO_PLATFORM ?= "fb"
EGLINFO_BINARY_NAME ?= "eglinfo-fb"
-# .bbappend files in BSP meta layers can add EGLINFO_DEVICE
-# values if necessary. eglinfo.inc contains default values for
-# the currently supported devices.
-# Consult the eglinfo README.md for details
-
include eglinfo.inc
SUMMARY += "(Framebuffer version)"
diff --git a/meta/recipes-graphics/eglinfo/eglinfo.inc b/meta/recipes-graphics/eglinfo/eglinfo.inc
index d53d0ff21e..785e7f15f3 100644
--- a/meta/recipes-graphics/eglinfo/eglinfo.inc
+++ b/meta/recipes-graphics/eglinfo/eglinfo.inc
@@ -13,15 +13,10 @@ S = "${WORKDIR}/git"
inherit waf
-# BSP layers should add .bbappend files for the -x11 and -fb .bb recipes,
-# which append the respective EGL/OpenGLES/OpenVG libraries to DEPENDS
-# not doing that here, since some platforms might not have OpenGL ES or OpenVG support
-# (in that case, the eglinfo build scripts automatically disable the relevant code paths)
-
+# BSP layers should add .bbappend files for the -x11 and -fb .bb recipes, which
+# append the respective EGL/OpenGLES/OpenVG libraries to DEPENDS and set
+# EGL_DEVICE as appropriate.
EGLINFO_DEVICE ?= "generic"
-EGLINFO_DEVICE_raspberrypi ?= "raspberrypi"
-EGLINFO_DEVICE_beagleboard ?= "beagleboard"
-EGLINFO_DEVICE_mx6 ?= "imx6"
EXTRA_OECONF = "--platform=${EGLINFO_PLATFORM} \
--device=${EGLINFO_DEVICE} \