summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-09-25 15:19:45 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-09-27 08:59:16 -0700
commit0f55d28a4d1f425343eb5aeae3eb7ffb3efd266a (patch)
tree50f89281614c8266ce092c1c6fb1865b4bf90098 /meta
parent5c8fad6544421e238da2ff33f5bbf1ed68fbc8be (diff)
downloadopenembedded-core-contrib-0f55d28a4d1f425343eb5aeae3eb7ffb3efd266a.tar.gz
glibc & eglibc: fix mips DT_MIPS_RLD_MAP checking
On mips target, binutils currently sets DT_MIPS_RLD_MAP to 0 in dynamic section if a --version-script sets _RLD_MAP to local. This is apparently a binutils bug, but libc shouldn't segfault in this case. Add sanity check on the entry to avoid segfault, fixes [BUGID #287]. Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch21
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.12.bb3
-rw-r--r--meta/recipes-core/glibc/glibc-2.10.1/mips-rld-map-check.patch21
-rw-r--r--meta/recipes-core/glibc/glibc_2.10.1.bb3
4 files changed, 46 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch b/meta/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch
new file mode 100644
index 0000000000..ed08d7e301
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch
@@ -0,0 +1,21 @@
+On mips target, binutils currently sets DT_MIPS_RLD_MAP to 0 in dynamic
+section if a --version-script sets _RLD_MAP to local. This is apparently
+a binutils bug, but libc shouldn't segfault in this case.
+
+see also: http://sourceware.org/bugilla/show_bug.cgi?id=11615
+
+9/19/2010 - added by Qing He <qing.he@intel.com>
+---
+diff -ru glibc-2.10.1.orig/ports/sysdeps/mips/dl-machine.h glibc-2.10.1/ports/sysdeps/mips/dl-machine.h
+--- glibc-2.10.1.orig/ports/sysdeps/mips/dl-machine.h 2009-05-16 16:36:20.000000000 +0800
++++ glibc-2.10.1/ports/sysdeps/mips/dl-machine.h 2010-09-19 09:11:53.000000000 +0800
+@@ -70,7 +70,8 @@
+ /* If there is a DT_MIPS_RLD_MAP entry in the dynamic section, fill it in
+ with the run-time address of the r_debug structure */
+ #define ELF_MACHINE_DEBUG_SETUP(l,r) \
+-do { if ((l)->l_info[DT_MIPS (RLD_MAP)]) \
++do { if ((l)->l_info[DT_MIPS (RLD_MAP)] && \
++ (l)->l_info[DT_MIPS (RLD_MAP)]->d_un.d_ptr) \
+ *(ElfW(Addr) *)((l)->l_info[DT_MIPS (RLD_MAP)]->d_un.d_ptr) = \
+ (ElfW(Addr)) (r); \
+ } while (0)
diff --git a/meta/recipes-core/eglibc/eglibc_2.12.bb b/meta/recipes-core/eglibc/eglibc_2.12.bb
index 1b633a7d47..7917fbdd7f 100644
--- a/meta/recipes-core/eglibc/eglibc_2.12.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.12.bb
@@ -2,13 +2,14 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
-PR = "r7"
+PR = "r8"
SRCREV="10809"
EGLIBC_BRANCH="eglibc-2_12"
SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
file://eglibc-svn-arm-lowlevellock-include-tls.patch \
file://IO-acquire-lock-fix.patch \
file://shorten-build-commands.patch \
+ file://mips-rld-map-check.patch \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
diff --git a/meta/recipes-core/glibc/glibc-2.10.1/mips-rld-map-check.patch b/meta/recipes-core/glibc/glibc-2.10.1/mips-rld-map-check.patch
new file mode 100644
index 0000000000..ed08d7e301
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc-2.10.1/mips-rld-map-check.patch
@@ -0,0 +1,21 @@
+On mips target, binutils currently sets DT_MIPS_RLD_MAP to 0 in dynamic
+section if a --version-script sets _RLD_MAP to local. This is apparently
+a binutils bug, but libc shouldn't segfault in this case.
+
+see also: http://sourceware.org/bugilla/show_bug.cgi?id=11615
+
+9/19/2010 - added by Qing He <qing.he@intel.com>
+---
+diff -ru glibc-2.10.1.orig/ports/sysdeps/mips/dl-machine.h glibc-2.10.1/ports/sysdeps/mips/dl-machine.h
+--- glibc-2.10.1.orig/ports/sysdeps/mips/dl-machine.h 2009-05-16 16:36:20.000000000 +0800
++++ glibc-2.10.1/ports/sysdeps/mips/dl-machine.h 2010-09-19 09:11:53.000000000 +0800
+@@ -70,7 +70,8 @@
+ /* If there is a DT_MIPS_RLD_MAP entry in the dynamic section, fill it in
+ with the run-time address of the r_debug structure */
+ #define ELF_MACHINE_DEBUG_SETUP(l,r) \
+-do { if ((l)->l_info[DT_MIPS (RLD_MAP)]) \
++do { if ((l)->l_info[DT_MIPS (RLD_MAP)] && \
++ (l)->l_info[DT_MIPS (RLD_MAP)]->d_un.d_ptr) \
+ *(ElfW(Addr) *)((l)->l_info[DT_MIPS (RLD_MAP)]->d_un.d_ptr) = \
+ (ElfW(Addr)) (r); \
+ } while (0)
diff --git a/meta/recipes-core/glibc/glibc_2.10.1.bb b/meta/recipes-core/glibc/glibc_2.10.1.bb
index 7f97273f70..364a0e5d12 100644
--- a/meta/recipes-core/glibc/glibc_2.10.1.bb
+++ b/meta/recipes-core/glibc/glibc_2.10.1.bb
@@ -5,7 +5,7 @@ ARM_INSTRUCTION_SET = "arm"
PACKAGES_DYNAMIC = "libc6*"
RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
-PR = "r5"
+PR = "r6"
# the -isystem in bitbake.conf screws up glibc do_stage
BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
@@ -54,6 +54,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
file://glibc-check_pf.patch;striplevel=0 \
file://ldd-unbash.patch \
file://glibc-arm-IO-acquire-lock-fix.diff \
+ file://mips-rld-map-check.patch \
file://generic-bits_select.h \
file://generic-bits_types.h \
file://generic-bits_typesizes.h \