summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-29 15:41:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:33 +0000
commit0564f7bbe8e06868e107b70d5abbf3dd6c113bad (patch)
tree76700bfd11d79eff0156db57516b84bc8386d003 /meta
parent1f0ad78b8fa739f9a68ed4c7bfae2b6d8586fda2 (diff)
downloadopenembedded-core-contrib-0564f7bbe8e06868e107b70d5abbf3dd6c113bad.tar.gz
python-smartpm: allow setting arbitrary macros in smart config
Add support for an rpm-extra-macros config option which can be used to define some extra macros that need to be set for rootfs construction to work on the host and that don't really warrant their own specific named config options to be created. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-rpm-extra-macros.patch27
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-rpm-extra-macros.patch b/meta/recipes-devtools/python/python-smartpm/smart-rpm-extra-macros.patch
new file mode 100644
index 0000000000..30cb1767dd
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-rpm-extra-macros.patch
@@ -0,0 +1,27 @@
+backends/rpm: implement rpm-extra-macros option
+
+Allow defining extra macros in the smart configuration to be passed
+to rpm before opening the database.
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/smart/backends/rpm/base.py b/smart/backends/rpm/base.py
+index b9e9cb2..234c844 100644
+--- a/smart/backends/rpm/base.py
++++ b/smart/backends/rpm/base.py
+@@ -53,6 +53,10 @@ def rpm_join_dbpath(root, dbpath):
+ return os.path.join(root, dbpath)
+
+ def getTS(new=False):
++ if sysconf.get("rpm-extra-macros"):
++ for key, value in sysconf.get("rpm-extra-macros").items():
++ rpm.addMacro(key, str(value))
++
+ rpm_root = os.path.abspath(sysconf.get("rpm-root", "/"))
+ if not hasattr(getTS, "ts") or getTS.root != rpm_root:
+ getTS.root = rpm_root
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 72a307d2b7..4694d517aa 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -19,6 +19,7 @@ SRC_URI = "\
file://smartpm-rpm5-nodig.patch \
file://smart-rpm-root.patch \
file://smart-recommends.patch \
+ file://smart-rpm-extra-macros.patch \
file://smart-dflags.patch \
file://smart-rpm-md-parse.patch \
file://smart-tmpdir.patch \