aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-19 18:03:38 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-19 18:03:38 +0100
commit0dc18c5339db880b656df68e5de1fb54dbf55405 (patch)
tree41b946096146870d016d28e114ab967e2ef08569 /meta
parent79542c9c7d44837ba0a80ddcd5cd2e9f6edc453e (diff)
downloadopenembedded-core-contrib-0dc18c5339db880b656df68e5de1fb54dbf55405.tar.gz
Add python-dbus, python-pyrex from OE.dev
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/python/files/pyrex-fix-optimized-mode.patch13
-rw-r--r--meta/packages/python/python-dbus_0.83.0.bb25
-rw-r--r--meta/packages/python/python-pyrex-native_0.9.8.5.bb10
-rw-r--r--meta/packages/python/python-pyrex_0.9.8.5.bb16
4 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/python/files/pyrex-fix-optimized-mode.patch b/meta/packages/python/files/pyrex-fix-optimized-mode.patch
new file mode 100644
index 0000000000..a1f5bb29ba
--- /dev/null
+++ b/meta/packages/python/files/pyrex-fix-optimized-mode.patch
@@ -0,0 +1,13 @@
+Index: Pyrex-0.9.8.4/Pyrex/Distutils/extension.py
+===================================================================
+--- Pyrex-0.9.8.4.orig/Pyrex/Distutils/extension.py
++++ Pyrex-0.9.8.4/Pyrex/Distutils/extension.py
+@@ -15,7 +15,7 @@ except ImportError:
+ warnings = None
+
+ class Extension(_Extension.Extension):
+- _Extension.Extension.__doc__ + \
++ _Extension.Extension.__doc__ or "" + \
+ """pyrex_include_dirs : [string]
+ list of directories to search for Pyrex header files (.pxd) (in
+ Unix form for portability)
diff --git a/meta/packages/python/python-dbus_0.83.0.bb b/meta/packages/python/python-dbus_0.83.0.bb
new file mode 100644
index 0000000000..275e60e329
--- /dev/null
+++ b/meta/packages/python/python-dbus_0.83.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+PR = "ml1"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+export BUILD_SYS
+export HOST_SYS
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+do_stage() {
+ autotools_stage_all
+}
+
+RDEPENDS = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig
diff --git a/meta/packages/python/python-pyrex-native_0.9.8.5.bb b/meta/packages/python/python-pyrex-native_0.9.8.5.bb
new file mode 100644
index 0000000000..4405212040
--- /dev/null
+++ b/meta/packages/python/python-pyrex-native_0.9.8.5.bb
@@ -0,0 +1,10 @@
+require python-pyrex_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}
diff --git a/meta/packages/python/python-pyrex_0.9.8.5.bb b/meta/packages/python/python-pyrex_0.9.8.5.bb
new file mode 100644
index 0000000000..03468a0522
--- /dev/null
+++ b/meta/packages/python/python-pyrex_0.9.8.5.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Pyrex is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCNAME = "Pyrex"
+PR = "ml1"
+
+SRC_URI = "\
+ http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://pyrex-fix-optimized-mode.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils