aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-16 18:49:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-18 07:39:30 +0000
commit012460d4ff714ee75f977c35af7749c5544da7b1 (patch)
treefab9dde4e91cf10f82eeffc95f0928c8f395b03e /meta
parentf770a6e0c2e1d687abab6f2bf79091b1068d1ccb (diff)
downloadopenembedded-core-contrib-012460d4ff714ee75f977c35af7749c5544da7b1.tar.gz
sqlite3: update 3.10.2 -> 3.11.0
http://www.sqlite.org/releaselog/3_11_0.html (From OE-Core rev: f92465c02ea6aef59f5e65a9eb70ebc6a5c92617) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/sqlite/sqlite3/fix-disable-static-shell.patch61
-rw-r--r--meta/recipes-support/sqlite/sqlite3/parallel.patch32
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3.11.0.bb (renamed from meta/recipes-support/sqlite/sqlite3_3.10.2.bb)6
3 files changed, 64 insertions, 35 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3/fix-disable-static-shell.patch b/meta/recipes-support/sqlite/sqlite3/fix-disable-static-shell.patch
new file mode 100644
index 0000000000..6f39ae2663
--- /dev/null
+++ b/meta/recipes-support/sqlite/sqlite3/fix-disable-static-shell.patch
@@ -0,0 +1,61 @@
+From ede5db83e38cc8ad8c9be291cd8985f7ad99f291 Mon Sep 17 00:00:00 2001
+From: Andre McCurdy <armccurdy@gmail.com>
+Date: Tue, 16 Feb 2016 14:00:00 -0800
+Subject: [PATCH] fix --disable-static-shell
+
+Upstream sqlite seems to be moving further and further away from
+allowing the sqlite3 command line tool to be dynamically linked with
+sqlite.
+
+The --disable-static-shell configure option added in 3.10.0 no longer
+has any effect in 3.11.0. For now patch things up and make it work.
+
+Upstream-Status: Pending
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+---
+ Makefile.am | 13 +++++++++++--
+ configure.ac | 2 +-
+ 2 files changed, 12 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 0e09cfc..608c0fd 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -6,9 +6,18 @@ libsqlite3_la_SOURCES = sqlite3.c
+ libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8
+
+ bin_PROGRAMS = sqlite3
+-sqlite3_SOURCES = shell.c sqlite3.c sqlite3.h
+-sqlite3_LDADD = @READLINE_LIBS@
++sqlite3_SOURCES = shell.c sqlite3.h
++EXTRA_sqlite3_SOURCES = sqlite3.c
++sqlite3_LDADD = @EXTRA_SHELL_OBJ@ @READLINE_LIBS@
+ sqlite3_DEPENDENCIES = @EXTRA_SHELL_OBJ@
++
++# Warning: Adding SQLITE_ENABLE_EXPLAIN_COMMENTS to sqlite3_CFLAGS doesn't
++# actually have any effect if we link the sqlite3 command line tool with the
++# libsqlite3.so shared library (which will contain a version of sqlite3.c
++# compiled with the default AM_CFLAGS above). If SQLITE_ENABLE_EXPLAIN_COMMENTS
++# debug is required, then sqlite3 must not be configured with
++# --disable-static-shell
++
+ sqlite3_CFLAGS = $(AM_CFLAGS) -DSQLITE_ENABLE_EXPLAIN_COMMENTS
+
+ include_HEADERS = sqlite3.h sqlite3ext.h
+diff --git a/configure.ac b/configure.ac
+index 8e7fd69..ada559e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -130,7 +130,7 @@ AC_ARG_ENABLE(static-shell, [AS_HELP_STRING(
+ [statically link libsqlite3 into shell tool [default=yes]])],
+ [], [enable_static_shell=yes])
+ if test x"$enable_static_shell" == "xyes"; then
+- EXTRA_SHELL_OBJ=sqlite3.$OBJEXT
++ EXTRA_SHELL_OBJ=sqlite3-sqlite3.$OBJEXT
+ else
+ EXTRA_SHELL_OBJ=libsqlite3.la
+ fi
+--
+1.9.1
+
diff --git a/meta/recipes-support/sqlite/sqlite3/parallel.patch b/meta/recipes-support/sqlite/sqlite3/parallel.patch
deleted file mode 100644
index 7b886a6bca..0000000000
--- a/meta/recipes-support/sqlite/sqlite3/parallel.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 140476c3e6a6f497bdd95c0c039cb9a680f5a414 Mon Sep 17 00:00:00 2001
-From: Andre McCurdy <armccurdy@gmail.com>
-Date: Fri, 22 Jan 2016 15:53:04 -0800
-Subject: [PATCH] parallel build fix
-
-When statically linking the sqlite3 binary, ensure that it depends on
-its own version of sqlite3.o, instead of the version being built (in
-parallel) for use in the libsqlite3.a static library.
-
-Upstream-Status: Pending
-
-Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index e9b3950..0e8f043 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -129,7 +129,7 @@ AC_ARG_ENABLE(static-shell, [AS_HELP_STRING(
- [statically link libsqlite3 into shell tool [default=yes]])],
- [], [enable_static_shell=yes])
- if test x"$enable_static_shell" == "xyes"; then
-- EXTRA_SHELL_OBJ=sqlite3.$OBJEXT
-+ EXTRA_SHELL_OBJ=sqlite3-sqlite3.$OBJEXT
- else
- EXTRA_SHELL_OBJ=libsqlite3.la
- fi
---
-1.9.1
-
diff --git a/meta/recipes-support/sqlite/sqlite3_3.10.2.bb b/meta/recipes-support/sqlite/sqlite3_3.11.0.bb
index 75fabc67a2..992d20cd5b 100644
--- a/meta/recipes-support/sqlite/sqlite3_3.10.2.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3.11.0.bb
@@ -4,8 +4,8 @@ LICENSE = "PD"
LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=65f0a57ca6928710b418c094b3570bb0"
SRC_URI = "http://www.sqlite.org/2016/sqlite-autoconf-${SQLITE_PV}.tar.gz \
- file://parallel.patch \
+ file://fix-disable-static-shell.patch \
"
-SRC_URI[md5sum] = "adaa31593bb5605ec6d6f34f81b43008"
-SRC_URI[sha256sum] = "a2b3b4bd1291ea7d6c8252f7edff36a4362f2f0e5d5370444ba6cbe313ae2971"
+SRC_URI[md5sum] = "a6cdc3e0a6e5087d620037ae0c48720d"
+SRC_URI[sha256sum] = "508d4dcbcf7a7181e95c717a1dc4ae3c0880b3d593be0c4b40abb6c3a0e201fb"