summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-08 16:46:50 +0000
committerAnuj Mittal <anuj.mittal@intel.com>2021-03-22 09:36:33 +0800
commitbb60d68c0cc8b2d1884e8d68966dffc563454c74 (patch)
tree38a29f2f78c997cce96d46b50ff5f057a92a98f7 /meta
parentb4620992fb5d81ca0bab3979297aa78fe00da85f (diff)
downloadopenembedded-core-contrib-bb60d68c0cc8b2d1884e8d68966dffc563454c74.tar.gz
build-appliance-image: Drop kernel module handling
kernel-devsrc is a dependency of the image so we no longer need the symlink creation code or the module-base inherit/dependency as it is included in that recipe. The KERNEL_VERSION usage was broken anyway as the module usage would have needed a: do_image[depends] += "build-appliance-image:do_configure" which wasn't present so it was indeterminate if KERNEL_VERSION was set correctly. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a46b43bb67b2f87ec370480e50a2e2d111555b75) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index ce73592fd3..15cb45e7a4 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -22,7 +22,7 @@ APPEND += "rootfstype=ext4 quiet"
DEPENDS = "zip-native python3-pip-native"
IMAGE_FSTYPES = "wic.vmdk"
-inherit core-image module-base setuptools3
+inherit core-image setuptools3
SRCREV ?= "3bd4bf96cce57d3e9286f75c0f12c8b36d706a1c"
SRC_URI = "git://git.yoctoproject.org/poky;branch=gatesgarth \
@@ -61,12 +61,6 @@ fakeroot do_populate_poky_src () {
# Place the README_VirtualBox_Toaster file in builders home folder.
cp ${WORKDIR}/README_VirtualBox_Toaster.txt ${IMAGE_ROOTFS}/home/builder/
- # Create a symlink, needed for out-of-tree kernel modules build
- if [ ! -e ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build ]; then
- rm -f ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
- lnr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
- fi
-
echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
echo "export LC_ALL=en_US.utf8" >> ${IMAGE_ROOTFS}/home/builder/.bashrc