aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-02-16 10:25:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-16 17:38:43 +0000
commite1b837ab1e1d48b73217c4f62a0f5aefc998d8bf (patch)
tree74d12b50708f71e9b341a83e5f06abbf1cbe5757 /meta
parent35bb619486d7f5721e8fa86c8744d4cea4d1746a (diff)
downloadopenembedded-core-contrib-e1b837ab1e1d48b73217c4f62a0f5aefc998d8bf.tar.gz
lsb: update init-functions and remove sendmail
According to LSB specification Ref1, LSB checks file /lib/lsb/init-functions. But for 64 bits system it is installed in /lib64. Install init-functions to /lib/lsb to conform with LSB specification. Link file /usr/lib/sendmail which points to /usr/sbin/sendmail is required by LSB according to Linux FHS[Ref 2]. But it should be done by packages which provides command sendmail such as msmtp, postfix and esmtp etc. Refs: 1 http://refspecs.linuxfoundation.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/iniscrptfunc.html 2 http://www.pathname.com/fhs/pub/fhs-2.3.html#SPECIFICOPTIONS13 Signed-off-by: Kai Kang <kai.kang@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb16
1 files changed, 3 insertions, 13 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index b4ef98eea7..f05c30cd2c 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -72,19 +72,18 @@ do_install(){
do_install_append(){
install -d ${D}${sysconfdir}/core-lsb
- install -d ${D}/${baselib}/lsb
for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon
do
install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb
done
- install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb
+
+ install -d ${D}/lib/lsb
+ install -m 0755 ${WORKDIR}/init-functions ${D}/lib/lsb
# creat links for LSB test
install -d ${D}/usr/lib/lsb
ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/install_initd
ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/remove_initd
- install -d ${D}/${libdir}
- ln -sf ${sbindir}/sendmail ${D}/${libdir}/sendmail
if [ "${TARGET_ARCH}" = "x86_64" ];then
cd ${D}
@@ -119,13 +118,4 @@ do_install_append(){
FILES_${PN} += "/lib64 \
/usr/lib/lsb \
${base_libdir}/lsb/* \
- ${libdir}/sendmail \
"
-
-# The sysroot/${libdir}/sendmail conflicts with esmtp's, and it's a
-# symlink to ${sbindir}/sendmail which is meaningless for sysroot, so
-# remove it.
-SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_sendmail"
-remove_sysroot_sendmail() {
- rm -r "${SYSROOT_DESTDIR}${libdir}/sendmail"
-}