aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-04-04 16:07:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-06 01:11:21 +0100
commitc62d6d119c107fc60894ba25e83c96536a1b423c (patch)
treee2a9193bf37e0d6f6d9c8bc843d41a8dc7b07d1b /meta
parent2abeafa7a43736d6fd8b8ecb22c6f3c840093870 (diff)
downloadopenembedded-core-contrib-c62d6d119c107fc60894ba25e83c96536a1b423c.tar.gz
self-hosted-image: decrease reserved space to 0.5%
The default amount of reserved space for ext2/3 is 5% - this amounts to about 2GB of a 40GB filesystem that the builder user can't make use of. We don't need this much reserved so peg it back to 0.5% which should be more than enough. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index d8fd4a963c..8adb683744 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -5,7 +5,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r9"
+PR = "r10"
IMAGE_FEATURES += "x11-mini package-management"
@@ -22,6 +22,11 @@ inherit core-image
SRCREV = "8691a588267472eb5a32b978a0eb9ddfd0c91733"
SRC_URI = "git://git.yoctoproject.org/poky;protocol=git"
+IMAGE_CMD_ext3_append () {
+ # We don't need to reserve much space for root, 0.5% is more than enough
+ tune2fs -m 0.5 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext3
+}
+
fakeroot do_populate_poky_src () {
# Because fetch2's git's unpack uses -s cloneflag, the unpacked git repo
# will become invalid in the target.