aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorYasir-Khan <yasir_khan@mentor.com>2014-09-08 12:58:41 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-10 11:29:50 +0100
commitc448bf3629ab5d930ed845d4ba48e37e4a85d2a3 (patch)
treec1b8a952362cf6c08e42e86a3e856bfc4b9986dd /meta
parente8eb01fb49bf18dedb62ef05712374cec3bd5efd (diff)
downloadopenembedded-core-contrib-c448bf3629ab5d930ed845d4ba48e37e4a85d2a3.tar.gz
python-native: disable user site support
The user site-packages gets inserted into sys.path ahead of the system site directories, so a site package installed there will be used in preference to what's in our sysroot, causing less deterministic builds, and potential build breakage, depending on what the user has installed there. Disable it for our native python, so they don't affect our builds. Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Yasir-Khan <yasir_khan@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
index 827654dfa2..e55f5feac2 100644
--- a/meta/recipes-devtools/python/python-native_2.7.3.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -58,4 +58,8 @@ do_install() {
# (these often end up too long for the #! parser in the kernel as the
# buffer is 128 bytes long).
ln -s python-native/python ${D}${bindir}/nativepython
+
+ # We don't want modules in ~/.local being used in preference to those
+ # installed in the native sysroot, so disable user site support.
+ sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
}