aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-11-28 02:59:54 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-05 17:43:14 +0000
commit113225b93c55d55a330fcca7d9f996ec039fb953 (patch)
treef4ca57e5c3402a2e703227eb8b98a1ef8231cf5d /meta
parentfafdf20179cf28b24459dc0263e4ba36e5843b85 (diff)
downloadopenembedded-core-contrib-113225b93c55d55a330fcca7d9f996ec039fb953.tar.gz
coreutils-native: don't install groups
This binary is provided by shadow-native nowadays. Fixes: ERROR: The recipe coreutils-native is trying to install files \ into a shared area when those files already exist. \ Those files and their manifest location are: \ .../tmp/sysroots/x86_64-linux/usr/bin/groups \ Matched in manifest-x86_64-shadow-native.populate_sysroot To reproduce the errors: $ bitbake shadow-native && bitbake coreutils-native Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.22.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.22.bb b/meta/recipes-core/coreutils/coreutils_8.22.bb
index 6239600c6d..f85bacabd3 100644
--- a/meta/recipes-core/coreutils/coreutils_8.22.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.22.bb
@@ -74,6 +74,11 @@ do_install_append() {
mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
}
+do_install_append_class-native(){
+ # remove groups to fix conflict with shadow-native
+ rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
+}
+
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"