aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-12-22 12:55:49 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-02 12:47:37 +0000
commitb180ede825dca8747c8c64dc2f23d64809a3ba95 (patch)
tree51c13e45f18e29fd54516c6aafc9c7460a16fbc0 /meta
parentd673ec1686631f4b146f59f8dc36287b65a5d95d (diff)
downloadopenembedded-core-contrib-b180ede825dca8747c8c64dc2f23d64809a3ba95.tar.gz
opkg-utils: tidy up recipe
* Update HOMEPAGE * Rearrange statements in logical order Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 10063e8f8c..714fc512e4 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -1,25 +1,27 @@
SUMMARY = "Additional utilities for the opkg package manager"
SECTION = "base"
-HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
+HOMEPAGE = "http://code.google.com/p/opkg/"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
-RDEPENDS_${PN} = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
-RDEPENDS_${PN}_class-native = ""
+
SRCREV = "757a1664a440c60e8126443bf984e4bdf374c327"
PV = "0.1.8+git${SRCPV}"
-SRC_URI = "git://git.yoctoproject.org/opkg-utils \
- "
+SRC_URI = "git://git.yoctoproject.org/opkg-utils"
S = "${WORKDIR}/git"
-# Avoid circular dependencies from package_ipk.bbclass
-PACKAGES_class-native = ""
+TARGET_CC_ARCH += "${LDFLAGS}"
do_install() {
oe_runmake PREFIX=${prefix} DESTDIR=${D} install
}
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES_class-native = ""
+
+RDEPENDS_${PN} = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
+RDEPENDS_${PN}_class-native = ""
+
BBCLASSEXTEND = "native"
-TARGET_CC_ARCH += "${LDFLAGS}"