aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-11-10 11:11:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-12 15:36:12 +0000
commit8c219ef79ce9855524e483d13b3c9559f9233eb1 (patch)
treebcbb5c7848497cbbf8369cff733001c0184bdbad /meta
parent8d280849b00b1e8ec0de906f6d2ad0b4dc31864a (diff)
downloadopenembedded-core-contrib-8c219ef79ce9855524e483d13b3c9559f9233eb1.tar.gz
gptfdisk: add 0.8.10+git version
Besides from being useful as fdisk replacement this gives us 'sgdisk' which can be used to set the GUID for partitions, e.g. sgdisk -t 1:C12A7328-F81F-11D2-BA4B-00A0C93EC93B /dev/mmcblk0p1 To mark it as ESP in scripts like mkefidisk.sh. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/fdisk/gptfdisk_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fdisk/gptfdisk_git.bb b/meta/recipes-devtools/fdisk/gptfdisk_git.bb
new file mode 100644
index 0000000000..477c1d986f
--- /dev/null
+++ b/meta/recipes-devtools/fdisk/gptfdisk_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+DEPENDS = "util-linux popt ncurses"
+
+PV = "0.8.10+git${SRCPV}"
+SRCREV = "a920398fa393f9d6301b32b191bc01e086ab8bc8"
+SRC_URI = "git://git.code.sf.net/p/gptfdisk/code"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 cgdisk ${D}${sbindir}
+ install -m 0755 gdisk ${D}${sbindir}
+ install -m 0755 sgdisk ${D}${sbindir}
+ install -m 0755 fixparts ${D}${sbindir}
+}
+
+BBCLASSEXTEND = "native nativesdk"