aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-04 09:43:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-07 13:40:34 +0100
commitbebf1ceb353cc38cb33e47f1a476079ab1b7f100 (patch)
tree51f778f57b0683ba5d398bd664692ab64af2bf4f /meta
parent6599783b85396004c2b8d5fc1ae0fafbaf8af625 (diff)
downloadopenembedded-core-contrib-bebf1ceb353cc38cb33e47f1a476079ab1b7f100.tar.gz
python3: Disable pip to fix issues on the Autobuilders
As Python-3.4 pip is required and installed by default, pips installation is bootstrapped using python wheels, this makes it complicated to patch, by default the installation uses an absolute path to /tmp, on most cases this would not be a problem, but since on the Autobuilders several Python installations (for different archs) may be happening at the same time, this shared resource utilization results in errors at do_install(), this patch disables pip installation by default for now, until we have a python3-pip package which we can easily patch in these situations. (From OE-Core rev: be2d305e3f5d675ed98bfe160357f87dc99a8675) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3_3.4.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.2.bb b/meta/recipes-devtools/python/python3_3.4.2.bb
index 8bd69ed282..0350de6116 100644
--- a/meta/recipes-devtools/python/python3_3.4.2.bb
+++ b/meta/recipes-devtools/python/python3_3.4.2.bb
@@ -62,7 +62,7 @@ TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
EXTRA_OEMAKE += "CROSS_COMPILE=yes"
-EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
+EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ --without-ensurepip"
export CROSS_COMPILE = "${TARGET_PREFIX}"
export _PYTHON_PROJECT_BASE = "${B}"