aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPhil Blundell <philb@brightsign.biz>2013-05-14 11:59:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:40:03 +0000
commitdd6998ee068f0edf20139fee80fbbf6c1347649d (patch)
treed9212b45add5d671f9dc69e82b92c9be222dee18 /meta
parent928973960d1e4d0797fe3569a07f6265368a6aff (diff)
downloadopenembedded-core-contrib-dd6998ee068f0edf20139fee80fbbf6c1347649d.tar.gz
openjade: Fix build if not installing libtool .la files
The openjade build system is slightly funky and does strange things with library dependencies. Fix it up so that it depends on the .so rather than the .la (which may not exist) for libraries from the sysroot. Signed-off-by: Phil Blundell <philb@brightsign.biz> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/openjade/openjade-1.3.2/no-libtool.patch20
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-1.3.2/no-libtool.patch b/meta/recipes-devtools/openjade/openjade-1.3.2/no-libtool.patch
new file mode 100644
index 0000000000..2f57c000f6
--- /dev/null
+++ b/meta/recipes-devtools/openjade/openjade-1.3.2/no-libtool.patch
@@ -0,0 +1,20 @@
+The openjade build is fairly unique in auto-generating explicit dependencies to
+installed .la files. As some distributions may delete these files unless
+clearly required, change the Makefile fragment to depend on the .so instead.
+
+Patch originally by Phil Blundell <philb@brightsign.biz>.
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+Upstream-Status: Inappropriate
+
+--- openjade-1.3.2/Makefile.prog.in~ 2013-05-14 11:42:02.646782318 +0100
++++ openjade-1.3.2/Makefile.prog.in 2013-05-14 11:54:55.051728343 +0100
+@@ -12,7 +12,7 @@
+
+ ALL_LIBS = $(XLIBS) $(LIBS)
+ Makefile.lt:
+- echo 'LT_LIBS='`echo $(ALL_LIBS) | sed 's/\.a\s/\.la /g' | sed s/\.a$$/\.la/` > Makefile.lt
++ echo 'LT_LIBS='`for d in $(ALL_LIBS); do case $$d in ../*) echo $$d | sed s/\.a$$/.la/g ;; *) echo $$d | sed s/\.a$$/.so/g ;; esac ; done` >Makefile.lt
+
+ PROG:=$(shell echo "$(PROG)" | sed '@program_transform_name@')
+
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
index a304daadf3..bc250080f1 100644
--- a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
+++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -17,7 +17,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
file://msggen.pl.patch \
file://reautoconf.patch \
file://user-declared-default-constructor.patch \
- file://fix-regex.patch"
+ file://fix-regex.patch \
+ file://no-libtool.patch"
SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1"