aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-07-10 16:54:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-01 11:04:38 +0100
commitcf2b41fd37c18d59e1fd309ac7693ad03599b08f (patch)
tree462763db7c6d373f70496628436139bc9d532f7b /meta
parentaadfac366bd2cae37357e15bf4fc28c159d71b32 (diff)
downloadopenembedded-core-contrib-cf2b41fd37c18d59e1fd309ac7693ad03599b08f.tar.gz
perl: fix build failure if building dir has the "blib" string
If build dir includes the string "blib", filter it out from @INC may empty the @INC and cause build errors like: Can't locate ExtUtils/MakeMaker.pm in @INC \ (you may need to install the ExtUtils::MakeMaker module) \ (@INC contains: .) at Makefile.PL Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.22.0.bb1
-rw-r--r--meta/recipes-devtools/perl/perl/perl-PathTools-don-t-filter-out-blib-from-INC.patch33
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.0.bb1
3 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.22.0.bb b/meta/recipes-devtools/perl/perl-native_5.22.0.bb
index dbcf2a6d49..a9a1cab942 100644
--- a/meta/recipes-devtools/perl/perl-native_5.22.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.22.0.bb
@@ -8,6 +8,7 @@ SRC_URI += "\
file://MM_Unix.pm.patch \
file://debian/errno_ver.diff \
file://dynaloaderhack.patch \
+ file://perl-PathTools-don-t-filter-out-blib-from-INC.patch \
"
SRC_URI[md5sum] = "ff0f09b17de426eff323426cb140ee79"
diff --git a/meta/recipes-devtools/perl/perl/perl-PathTools-don-t-filter-out-blib-from-INC.patch b/meta/recipes-devtools/perl/perl/perl-PathTools-don-t-filter-out-blib-from-INC.patch
new file mode 100644
index 0000000000..7dd904140a
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl/perl-PathTools-don-t-filter-out-blib-from-INC.patch
@@ -0,0 +1,33 @@
+From 90c252cecc38aed5d5faedb30485dd6eee2e54eb Mon Sep 17 00:00:00 2001
+From: Wenzong Fan <wenzong.fan@windriver.com>
+Date: Wed, 11 Feb 2015 15:14:40 +0800
+Subject: [PATCH] perl / PathTools: don't filter out blib from @INC
+
+If $TOPDIR includes the string "blib", filter it out from @INC may empty
+the @INC and cause build errors like:
+
+ Can't locate ExtUtils/MakeMaker.pm in @INC \
+ (you may need to install the ExtUtils::MakeMaker module) \
+ (@INC contains: .) at Makefile.PL
+
+Upstream-Status: Pending
+
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+---
+ dist/PathTools/Makefile.PL | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/dist/PathTools/Makefile.PL b/dist/PathTools/Makefile.PL
+index 1b21de4..f562cb2 100644
+--- a/dist/PathTools/Makefile.PL
++++ b/dist/PathTools/Makefile.PL
+@@ -1,6 +1,3 @@
+-
+-BEGIN { @INC = grep {!/blib/} @INC }
+-
+ require 5.005;
+ use ExtUtils::MakeMaker;
+ WriteMakefile
+--
+1.9.1
+
diff --git a/meta/recipes-devtools/perl/perl_5.22.0.bb b/meta/recipes-devtools/perl/perl_5.22.0.bb
index f72afa706f..e3a7f41886 100644
--- a/meta/recipes-devtools/perl/perl_5.22.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.0.bb
@@ -61,6 +61,7 @@ SRC_URI += " \
file://t-run-switches.t-perl5-perl.patch \
file://ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch \
file://ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch \
+ file://perl-PathTools-don-t-filter-out-blib-from-INC.patch \
"
# Fix test case issues