aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-14 16:57:23 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-08 17:32:43 +0100
commit7c6edfbc09efb64fd9ce9f56b1e1a1b7a6bdeef0 (patch)
treed898a1a2d3dc5a50e45ac22705816772352b0a3e /meta
parent8922e609cb947e34cde6e48b82ff37a932d8d8db (diff)
downloadopenembedded-core-contrib-7c6edfbc09efb64fd9ce9f56b1e1a1b7a6bdeef0.tar.gz
python3-pip: Adds recipe for python3-pip
PIP is installed by default since python 3.4, due to issues with the autobuilders, its default installation had to be disabled, this creates a recipe for it, it brings a lot of new dependencies so it is chosen not to be installed by default along with python3-core. [YOCTO #7762] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-pip_6.1.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_6.1.1.bb b/meta/recipes-devtools/python/python3-pip_6.1.1.bb
new file mode 100644
index 0000000000..7bfc30e2ae
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_6.1.1.bb
@@ -0,0 +1,40 @@
+SUMMARY = "The PyPA recommended tool for installing Python packages"
+sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=45665b53032c02b35e29ddab8e61fa91"
+
+SRCNAME = "pip"
+DEPENDS += "python3 python3-setuptools-native"
+
+SRC_URI = " \
+ http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "6b19e0a934d982a5a4b798e957cb6d45"
+SRC_URI[sha256sum] = "89f3b626d225e08e7f20d85044afa40f612eb3284484169813dc2d0631f2a556"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils3
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+# Use setuptools site.py instead, avoid shared state issue
+do_install_append() {
+ rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py
+ rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-34.pyc
+}
+
+RDEPENDS_${PN} = "\
+ python3-compile \
+ python3-io \
+ python3-json \
+ python3-netserver \
+ python3-setuptools \
+ python3-unixadmin \
+ python3-xmlrpc \
+"