aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2013-11-11 15:52:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-12 10:24:26 +0000
commitabf01e2f36943b5a5c5d2d827186054a51902130 (patch)
tree70a82b7236fd987a4f85cb565558b01dfc54fede /meta
parent9811641e95dd7e1514eb41900e033a0548bd13d8 (diff)
downloadopenembedded-core-contrib-abf01e2f36943b5a5c5d2d827186054a51902130.tar.gz
elfutils: remove eu-objdump if it does not work
[YOCTO #5283] eu-objdump does not work on mips, arm and ppc, so remove it from these unsupported architectures Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.155.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.155.bb b/meta/recipes-devtools/elfutils/elfutils_0.155.bb
index 1a8c3c7e8c..594dfb09ea 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.155.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.155.bb
@@ -47,6 +47,12 @@ do_configure_prepend() {
cp ${WORKDIR}/*dis.h ${S}/libcpu
}
+do_install_append() {
+ if [ "${TARGET_ARCH}" != "x86_64" ] && [ ! `echo "${TARGET_ARCH}"|grep -q 'i.86'` ];then
+ rm ${D}${bindir}/eu-objdump
+ fi
+}
+
# we can not build complete elfutils when using uclibc
# but some recipes e.g. gcc 4.5 depends on libelf so we
# build only libelf for uclibc case