aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 09:43:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 18:30:06 +0100
commit86bbe5b7b8e8f0c6ee88888fa083053ae14765c4 (patch)
tree6bc65fd29484d1f01b442d7f20af2e1673c1323b /meta
parent3b627b0a8e91a08a3e2a44c71d312ae303fb5d62 (diff)
downloadopenembedded-core-contrib-86bbe5b7b8e8f0c6ee88888fa083053ae14765c4.tar.gz
gcc-target: Combine gcc-target-configure.inc, gcc-target-package.inc and other common code
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-target.inc8
-rw-r--r--meta/recipes-devtools/gcc/gcc-target.inc (renamed from meta/recipes-devtools/gcc/gcc-package-target.inc)11
-rw-r--r--meta/recipes-devtools/gcc/gcc_4.7.bb5
-rw-r--r--meta/recipes-devtools/gcc/gcc_4.8.bb5
4 files changed, 13 insertions, 16 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-configure-target.inc b/meta/recipes-devtools/gcc/gcc-configure-target.inc
deleted file mode 100644
index 5f608d6bdf..0000000000
--- a/meta/recipes-devtools/gcc/gcc-configure-target.inc
+++ /dev/null
@@ -1,8 +0,0 @@
-GCCMULTILIB = "--enable-multilib"
-require gcc-configure-common.inc
-
-EXTRA_OECONF_PATHS = " \
- --with-sysroot=/ \
- --with-build-sysroot=${STAGING_DIR_TARGET} \
- --with-native-system-header-dir=${STAGING_DIR_TARGET}${target_includedir} \
- --with-gxx-include-dir=${includedir}/c++/ --enable-dependency-tracking"
diff --git a/meta/recipes-devtools/gcc/gcc-package-target.inc b/meta/recipes-devtools/gcc/gcc-target.inc
index 95a92c1f91..150fbba419 100644
--- a/meta/recipes-devtools/gcc/gcc-package-target.inc
+++ b/meta/recipes-devtools/gcc/gcc-target.inc
@@ -1,3 +1,14 @@
+GCCMULTILIB = "--enable-multilib"
+require gcc-configure-common.inc
+
+EXTRA_OECONF_PATHS = " \
+ --with-sysroot=/ \
+ --with-build-sysroot=${STAGING_DIR_TARGET} \
+ --with-native-system-header-dir=${STAGING_DIR_TARGET}${target_includedir} \
+ --with-gxx-include-dir=${includedir}/c++/ --enable-dependency-tracking"
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR} -I${B}/gcc/include/ "
+
PACKAGES = "\
${PN} ${PN}-plugins ${PN}-symlinks \
g++ g++-symlinks \
diff --git a/meta/recipes-devtools/gcc/gcc_4.7.bb b/meta/recipes-devtools/gcc/gcc_4.7.bb
index f68c67a403..0ae22e8fa3 100644
--- a/meta/recipes-devtools/gcc/gcc_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc_4.7.bb
@@ -1,5 +1,2 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require gcc-configure-target.inc
-require gcc-package-target.inc
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR} -I${B}/gcc/include/ "
+require gcc-target.inc
diff --git a/meta/recipes-devtools/gcc/gcc_4.8.bb b/meta/recipes-devtools/gcc/gcc_4.8.bb
index f68c67a403..0ae22e8fa3 100644
--- a/meta/recipes-devtools/gcc/gcc_4.8.bb
+++ b/meta/recipes-devtools/gcc/gcc_4.8.bb
@@ -1,5 +1,2 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require gcc-configure-target.inc
-require gcc-package-target.inc
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR} -I${B}/gcc/include/ "
+require gcc-target.inc