aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-08-13 20:31:23 -0500
committerSaul Wold <sgw@linux.intel.com>2013-08-22 09:15:34 -0700
commit6d7f5581bbfaf174edb77d92846e720e8057481c (patch)
treef5fefcd05919ad1f0ffce46a34cdc409e5927049 /meta
parent63c61b7c0c8aeb89661e3bb85e281dd1ef5b618c (diff)
downloadopenembedded-core-contrib-6d7f5581bbfaf174edb77d92846e720e8057481c.tar.gz
package_ipk: Add support for PACKAGE_EXCLUDE
This uses the new --add-exclude arguments in opkg-cl, to list the excluded packages. If an excluded package is needed for the install to resolve, an error will be generated. Recommended packages will not generate an error. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/package_ipk.bbclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index 69a6d95362..68ffc62583 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -12,6 +12,7 @@ OPKGBUILDCMD ??= "opkg-build"
OPKG_ARGS = "-f $INSTALL_CONF_IPK -o $INSTALL_ROOTFS_IPK --force_postinstall --prefer-arch-to-version"
OPKG_ARGS += "${@['', '--no-install-recommends'][d.getVar("NO_RECOMMENDATIONS", True) == "1"]}"
+OPKG_ARGS += "${@['', '--add-exclude ' + ' --add-exclude '.join((d.getVar('PACKAGE_EXCLUDE', True) or "").split())][(d.getVar("PACKAGE_EXCLUDE", True) or "") != ""]}"
OPKGLIBDIR = "${localstatedir}/lib"