aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-10-06 17:05:09 +0000
committerRichard Purdie <richard@openedhand.com>2008-10-06 17:05:09 +0000
commit61ec403176f292b541875012320038dbd8f404c4 (patch)
treed93359a7d99ba342c349c222731a246b66d76329 /meta
parentceb72549549583eed7bd7debdec62408802911ef (diff)
downloadopenembedded-core-contrib-61ec403176f292b541875012320038dbd8f404c4.tar.gz
rpm: Add python module packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5423 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/rpm/rpm_4.4.2.3.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb
index ef6087893c..3083387d87 100644
--- a/meta/packages/rpm/rpm_4.4.2.3.bb
+++ b/meta/packages/rpm/rpm_4.4.2.3.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The RPM Package Manager."
HOMEPAGE = "http://rpm.org/"
LICENSE = "LGPL GPL"
DEPENDS = "zlib beecrypt file popt python"
-PR = "r9"
+PR = "r10"
SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
file://external-tools.patch;patch=1 \
@@ -20,13 +20,16 @@ acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
EXTRA_OECONF = "--with-python=$PYTHONVER \
--with-python-incdir=${STAGING_INCDIR}/python$PYTHONVER \
- --with-python-libdir=${STAGING_LIBDIR}/python$PYTHONVER \
+ --with-python-libdir=${libdir}/python$PYTHONVER \
--without-apidocs \
--without-selinux \
--without-lua \
--without-dmalloc \
--without-efence"
+PACKAGES += "python-rpm"
+FILES_python-rpm = "${libdir}/python*/site-packages/rpm/_*"
+
# Handle the db MUTEX settings here, the POSIX library is
# the default - "POSIX/pthreads/library".
# Don't ignore the nice SWP instruction on the ARM: