summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/qt5/qtwayland_git.bbappend
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-26 09:23:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commite45f3d305e25ff2aef9e42697e583e6f69a9b6e6 (patch)
tree0bf698ed62d258d6e05d5a3129dea2e52b2d2121 /meta/recipes-webos/qt5/qtwayland_git.bbappend
parentc44fc9b620f762ce68441f834e1a157288a488e6 (diff)
downloadopenembedded-core-contrib-e45f3d305e25ff2aef9e42697e583e6f69a9b6e6.tar.gz
meta-webosose: import recipes which often reproduce Yocto #12434
* just temporary to make it easier to reproduce, import big part of meta-webosose and some recipes from meta-oe * luna-init: /luna-init-fonts/usr/share/fonts/PreludeCompWGL-Light.ttf is owned by uid 1001, which is the same as the user running bitbake. This may be due to host contamination * qml-webos-framework: /qml-webos-framework/usr/share/dbus-1/system-services/com.webos.qml-app.service is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=luna-init; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-webos/qt5/qtwayland_git.bbappend')
-rw-r--r--meta/recipes-webos/qt5/qtwayland_git.bbappend40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-webos/qt5/qtwayland_git.bbappend b/meta/recipes-webos/qt5/qtwayland_git.bbappend
new file mode 100644
index 0000000000..43055fe82f
--- /dev/null
+++ b/meta/recipes-webos/qt5/qtwayland_git.bbappend
@@ -0,0 +1,40 @@
+# Copyright (c) 2013-2018 LG Electronics, Inc.
+
+SUMMARY = "luna-surfacemanager qtwayland "
+AUTHOR = "Anupam Kaul <anupam.kaul@lge.com>"
+
+DEPENDS += "webos-wayland-extensions qt-features-webos"
+
+WEBOS_VERSION = "5.4.2-1_ee4a49f2ab723631174d7f2b8dae2263565c9ece"
+EXTENDPRAUTO_append = "webos13"
+
+# Upstream 5.5.0 recipe updated LIC_FILES_CHKSUM
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \
+ file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+inherit webos_enhanced_submissions
+inherit webos_qmake5
+inherit webos_lttng
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# Assume we're using the same Qt version to this component has.
+QT_VERSION = "${WEBOS_COMPONENT_VERSION}"
+
+inherit webos_public_repo
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+# By default the recipe will not compile any specific backend for the compositor.
+QT_WAYLAND_CONFIG_append = " CONFIG+=wayland_egl"
+QT_WAYLAND_DEFINES_append = "QT_COMPOSITOR_QUICK"
+
+# Enable LTTng tracing capability when enabled in webos_lttng class
+EXTRA_QMAKEVARS_PRE += "${@oe.utils.conditional('WEBOS_LTTNG_ENABLED', '1', 'CONFIG+=lttng', '', d)}"
+
+EXTRA_QMAKEVARS_POST += "CONFIG-=create_cmake"