summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/python-tz/python-tz-native_2015.4.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-26 09:23:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commite45f3d305e25ff2aef9e42697e583e6f69a9b6e6 (patch)
tree0bf698ed62d258d6e05d5a3129dea2e52b2d2121 /meta/recipes-webos/python-tz/python-tz-native_2015.4.bb
parentc44fc9b620f762ce68441f834e1a157288a488e6 (diff)
downloadopenembedded-core-contrib-e45f3d305e25ff2aef9e42697e583e6f69a9b6e6.tar.gz
meta-webosose: import recipes which often reproduce Yocto #12434
* just temporary to make it easier to reproduce, import big part of meta-webosose and some recipes from meta-oe * luna-init: /luna-init-fonts/usr/share/fonts/PreludeCompWGL-Light.ttf is owned by uid 1001, which is the same as the user running bitbake. This may be due to host contamination * qml-webos-framework: /qml-webos-framework/usr/share/dbus-1/system-services/com.webos.qml-app.service is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=luna-init; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-webos/python-tz/python-tz-native_2015.4.bb')
-rw-r--r--meta/recipes-webos/python-tz/python-tz-native_2015.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-webos/python-tz/python-tz-native_2015.4.bb b/meta/recipes-webos/python-tz/python-tz-native_2015.4.bb
new file mode 100644
index 0000000000..f3880b3f84
--- /dev/null
+++ b/meta/recipes-webos/python-tz/python-tz-native_2015.4.bb
@@ -0,0 +1,22 @@
+# Copyright (c) 2014-2015 LG Electronics, Inc.
+
+SUMMARY = "pytz brings the Olson tz database into Python"
+
+DESCRIPTION="This library allows accurate and cross platform timezone calculations using Python 2.4 or higher"
+
+HOMEPAGE = "https://pypi.python.org/pypi/pytz/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22b38951eb857cf285a4560a914b7cd6"
+
+PR = "r1"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pytz/pytz-${PV}.tar.gz \
+ file://fix.for.tzdata-2015e.patch \
+"
+SRC_URI[md5sum] = "417a47b1c432d90333e42084a605d3d8"
+SRC_URI[sha256sum] = "c4ee70cb407f9284517ac368f121cf0796a7134b961e53d9daf1aaae8f44fb90"
+
+S="${WORKDIR}/pytz-${PV}"
+
+inherit native
+inherit setuptools