summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/luna-prefs
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-26 09:23:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commite45f3d305e25ff2aef9e42697e583e6f69a9b6e6 (patch)
tree0bf698ed62d258d6e05d5a3129dea2e52b2d2121 /meta/recipes-webos/luna-prefs
parentc44fc9b620f762ce68441f834e1a157288a488e6 (diff)
downloadopenembedded-core-contrib-e45f3d305e25ff2aef9e42697e583e6f69a9b6e6.tar.gz
meta-webosose: import recipes which often reproduce Yocto #12434
* just temporary to make it easier to reproduce, import big part of meta-webosose and some recipes from meta-oe * luna-init: /luna-init-fonts/usr/share/fonts/PreludeCompWGL-Light.ttf is owned by uid 1001, which is the same as the user running bitbake. This may be due to host contamination * qml-webos-framework: /qml-webos-framework/usr/share/dbus-1/system-services/com.webos.qml-app.service is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=luna-init; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-webos/luna-prefs')
-rw-r--r--meta/recipes-webos/luna-prefs/luna-prefs-data.bb47
-rw-r--r--meta/recipes-webos/luna-prefs/luna-prefs.bb32
2 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-webos/luna-prefs/luna-prefs-data.bb b/meta/recipes-webos/luna-prefs/luna-prefs-data.bb
new file mode 100644
index 0000000000..cd6b3844c6
--- /dev/null
+++ b/meta/recipes-webos/luna-prefs/luna-prefs-data.bb
@@ -0,0 +1,47 @@
+# Copyright (c) 2015 LG Electronics, Inc.
+
+# WARNING: This recipe appears in the SIGGEN_EXCLUDERECIPES_ABISAFE list in
+# conf/layer.conf which means that changes to it will not be used in the generation
+# of sstate signatures. This is unlikely to cause problems, unless luna-prefs is
+# changed to no longer use the files under /etc/prefs/properties to determine the
+# properties its exposes and their values.
+
+SUMMARY = "Preferences Manager data for ${MACHINE}"
+AUTHOR = "Oleksandr Ivanov <oleksandr.ivanov@lge.com>"
+SECTION = "webos/base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PV = "3.0.0"
+PR = "r1"
+
+inherit webos_machine_dep
+
+PRODUCT_DEVICE_NAME ?= "${DISTRO_NAME} Device"
+PRODUCT_DEVICE_NAME_BRANDED ?= "LGE ${DISTRO_NAME} Device"
+PRODUCT_DEVICE_NAME_SHORT ?= "${DISTRO_NAME} Device"
+PRODUCT_DEVICE_NAME_SHORT_BRANDED ?= "LGE ${DISTRO_NAME} Device"
+PRODUCT_DEVICE_NAME_PRODUCT_LINE_NAME ?= "${DISTRO_NAME} Device"
+PRODUCT_DEVICE_NAME_PRODUCT_CLASS ?= "${DISTRO_NAME}"
+PRODUCT_DEVICE_NAME_PRODUCT_BROWSER_OS_NAME ?= "${DISTRO_NAME}"
+
+# Versions can not be overridden
+PRODUCT_DEVICE_NAME_PRODUCT_BROWSER_OS_VERSION = "${WEBOS_DISTRO_API_VERSION}"
+
+do_install() {
+ install -d ${D}${sysconfdir}/prefs/properties
+
+ echo -n "${PRODUCT_DEVICE_NAME}" > ${D}${sysconfdir}/prefs/properties/deviceName
+ echo -n "${PRODUCT_DEVICE_NAME_BRANDED}" > ${D}${sysconfdir}/prefs/properties/deviceNameBranded
+ echo -n "${PRODUCT_DEVICE_NAME_SHORT}" > ${D}${sysconfdir}/prefs/properties/deviceNameShort
+ echo -n "${PRODUCT_DEVICE_NAME_SHORT_BRANDED}" > ${D}${sysconfdir}/prefs/properties/deviceNameShortBranded
+ echo -n "${MACHINE}" > ${D}${sysconfdir}/prefs/properties/machineName
+ echo -n "${PRODUCT_DEVICE_NAME_PRODUCT_LINE_NAME}" > ${D}${sysconfdir}/prefs/properties/productLineName
+ echo -n "${PRODUCT_DEVICE_NAME_PRODUCT_CLASS}" > ${D}${sysconfdir}/prefs/properties/productClass
+ echo -n "${PRODUCT_DEVICE_NAME_PRODUCT_BROWSER_OS_NAME}" > ${D}${sysconfdir}/prefs/properties/browserOsName
+ if [ "webOS" = "${PRODUCT_DEVICE_NAME_PRODUCT_BROWSER_OS_NAME}" ]
+ then
+ echo -n "${PRODUCT_DEVICE_NAME_PRODUCT_BROWSER_OS_VERSION}" > ${D}${sysconfdir}/prefs/properties/browserOsVersion
+ fi
+}
+
diff --git a/meta/recipes-webos/luna-prefs/luna-prefs.bb b/meta/recipes-webos/luna-prefs/luna-prefs.bb
new file mode 100644
index 0000000000..b1b03ac8e0
--- /dev/null
+++ b/meta/recipes-webos/luna-prefs/luna-prefs.bb
@@ -0,0 +1,32 @@
+# Copyright (c) 2012-2018 LG Electronics, Inc.
+
+SUMMARY = "webOS preferences manager"
+AUTHOR = "Oleksandr Ivanov <oleksandr.ivanov@lge.com>"
+SECTION = "webos/base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "luna-service2 cjson sqlite3 glib-2.0 nyx-lib"
+RDEPENDS_${PN} = "luna-prefs-data"
+
+WEBOS_VERSION = "3.0.0-1_0827814ccdc5ebe2b372d90120427043cc6ac94e"
+PR = "r12"
+
+#inherit webos_component
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit webos_program
+inherit webos_library
+inherit webos_system_bus
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # CFISH-930: remove "other" perms granted by pmmakefiles (aka palmmake):
+ chmod o-rwx ${D}${bindir}/luna-prefs-service
+ chmod o-rwx ${D}${bindir}/lunaprop
+
+}
+