summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/luna-init/luna-init.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-26 09:23:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commite45f3d305e25ff2aef9e42697e583e6f69a9b6e6 (patch)
tree0bf698ed62d258d6e05d5a3129dea2e52b2d2121 /meta/recipes-webos/luna-init/luna-init.bb
parentc44fc9b620f762ce68441f834e1a157288a488e6 (diff)
downloadopenembedded-core-contrib-e45f3d305e25ff2aef9e42697e583e6f69a9b6e6.tar.gz
meta-webosose: import recipes which often reproduce Yocto #12434
* just temporary to make it easier to reproduce, import big part of meta-webosose and some recipes from meta-oe * luna-init: /luna-init-fonts/usr/share/fonts/PreludeCompWGL-Light.ttf is owned by uid 1001, which is the same as the user running bitbake. This may be due to host contamination * qml-webos-framework: /qml-webos-framework/usr/share/dbus-1/system-services/com.webos.qml-app.service is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=luna-init; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-webos/luna-init/luna-init.bb')
-rw-r--r--meta/recipes-webos/luna-init/luna-init.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-webos/luna-init/luna-init.bb b/meta/recipes-webos/luna-init/luna-init.bb
new file mode 100644
index 0000000000..5be37da91b
--- /dev/null
+++ b/meta/recipes-webos/luna-init/luna-init.bb
@@ -0,0 +1,45 @@
+# Copyright (c) 2012-2018 LG Electronics, Inc.
+
+SUMMARY = "Initialization, setup, and font files used by luna-sysmgr and luna-sysservice"
+AUTHOR = "Alekseyev Oleksandr <alekseyev.oleksandr@lge.com>"
+SECTION = "webos/base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "tzdata python-tz-native"
+
+WEBOS_VERSION = "2.0.1-1_701ec4b373b776fba829c882b05ae19de9a476ed"
+PR = "r14"
+
+#inherit webos_component TODO
+inherit webos_arch_indep
+inherit webos_public_repo
+inherit webos_enhanced_submissions
+inherit webos_cmake
+inherit pythonnative
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Expand fonts tarball
+ if [ -e ${S}/files/conf/fonts/fonts.tgz ]; then
+ install -d ${D}${datadir}/fonts
+ tar xvzf ${S}/files/conf/fonts/fonts.tgz --directory=${D}${datadir}/fonts
+ fi
+ install -d ${D}${webos_sysconfdir}
+ install -v -m 644 ${S}/files/conf/locale.txt ${D}${webos_sysconfdir}
+}
+
+do_install_append_webos() {
+ install -v -m 644 ${S}/files/conf/apollo/defaultPreferences.txt ${D}${webos_sysconfdir}
+}
+
+PACKAGES =+ "${PN}-fonts"
+FILES_${PN} += "${webos_prefix} ${webos_sysconfdir}"
+FILES_${PN}-fonts += "${datadir}/fonts/"
+
+# until pseudo is completely fixed
+# PLAT-48507 pseudo: random package_qa failures
+# This issue seems to be triggered only in luna-init-fonts packages
+#INSANE_SKIP_${PN}-fonts += "host-user-contaminated"